Have you tried the username you designated for Codestriker in your apache configuration file? Maybe you can put that username in your /etc/group file.




From: codestriker-user-bounces@lists.sourceforge.net [mailto:codestriker-user-bounces@lists.sourceforge.net] On Behalf Of David Carson
Sent: Tuesday, January 22, 2008 8:59 PM
To: Codestriker-user@lists.sourceforge.net
Subject: [Codestriker-user] rdiff failed -- permission problem


On behalf of what user does the rdiff command run when using start and end tags?  Currently I have two different deployments.  One of them allows me to create a new topic using start and end tags.  The other does not, but I can't see any difference.

For the deployment that doesn't work, I can run rdiff from the command line and it works fine.  When I use codestriker, I get the following:

Problem generating topic text:

cvs rdiff: failed to create lock directory for `/export/cvsroot/elvis/extreme/evpages' (/var/lock/cvs/elvis/extreme/evpages/#cvs.lock): Permission denied
cvs rdiff: failed to obtain dir lock in repository `/export/cvsroot/elvis/extreme/evpages'
cvs [rdiff aborted]: read lock failed - giving up

(Note that we have configured CVS to place locks outside the repository.)

Since I can run rdiff as user X from the command line, I know that I have permissions to do so.  My theory is that when I create the topic and Codestriker runs rdiff, it uses a different user and hence the problem.  I tried adding 'apache' to our /etc/group, which is how we control who can write a lock to /var/lock/cvs.  This did not help.

Any ideas about the user?  Any other potential reasons this should fail when it works on the command line?  What else can I compare between the two deployments besides the config files?