codestrike under IIS+w2003

Help
2005-12-19
2013-06-03
  • Yahor Sinkevich

    Yahor Sinkevich - 2005-12-19

    Problems I found trying using codestrike under w2003 & IIS:

    1. During installation I've found strange problems with installing "Template" module. I've installed it successfully with PPM2, it was failed with PPM3. I dont know why, I'm not Perl guru (.

    2. I've not found codestriker.pl in the zip archive, so I downloaded it using WEB acces to the CVS.

    3. After I've installed Perl, Perl CGI was prohibited, so allowed Perl in the IIS Snap-in. (subject 4 docs)

    4. After I've opened codestriker.pl in the browser I got folowing error: "CGI Error
    The specified CGI application misbehaved by not returning a complete set of HTTP headers.", I've solved this problem by removing 1'st line - "#!/usr/bin/perl -wT" from the codestriker.pl (subject 4 docs)

    5. In the next step I've got error "Can't locate Codestriker.pm in @INC (@INC contains: /var/www/codestriker/lib C:/Perl/lib C:/Perl/site/lib .) at D:\Distr\CodeStriker\codestriker-1.9.1\bin\codestriker.pl line 26.
    BEGIN failed--compilation aborted at D:\Distr\CodeStriker\codestriker-1.9.1\bin\codestriker.pl line 26."

    So I've changed 26 line to "../lib" (subject 4 docs)

    6. Next I've got new error ) "Can't locate Codestriker/Action/SubmitTopic.pm in @INC (@INC contains: ../lib C:/Perl/lib C:/Perl/site/lib .) at D:\Distr\CodeStriker\codestriker-1.9.1\bin\codestriker.pl line 30.
    BEGIN failed--compilation aborted at D:\Distr\CodeStriker\codestriker-1.9.1\bin\codestriker.pl line 30"

    And I dont know wot to fix it (.

    Could you please:
    1. Help me fix the error (I think Its good Idea to update installation docs according to my experience and installing under IIS 6.0)

    2. Why there is no codestriker.pl in the zip archive?

    Thanks!

     
    • David Sitsky

      David Sitsky - 2005-12-19

      All of these errors are related to your problem as specified in the previous post.  The codestriker.pl file is to be generated from running install.pl.  Cut and paste the output here so we can try and debug the problem.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks