1.9.1 install.pl problem w/ remote MySQL DB

  • Manny

    Manny - 2006-03-24


    I am getting a DB authentication error when I run install.pl

    The db value in my codestriker.conf file is set to


    host "winvideo1" has MySQL v 4.1.7 and has been configured w/ a 'codestriker' database per installation instructions.  I can access it remotely w/ a mysql client version 5.0.18 this way:
      mysql -u codestriker -h winvideo1

    The same mysql command w/ a pre 5.0 version results in a similar authentication error.

    The mysql v 5.0.18 client is included in my PATH.

    And I get the following error when I run install.pl :

    Checking for  LWP::UserAgent (any)     ok: found v2.001
    Checking for         CGI (v2.56)   ok: found v2.81
    Checking for   Net::SMTP (any)     ok: found v2.24
    Checking for         DBI (v1.13)   ok: found v1.29
    Checking for    Template (v2.07)   ok: found v2.14
    Checking for HTML::Entities (any)  ok: found v1.23
    Checking for  File::Temp (any)     ok: found v0.12
    Checking for    XML::RSS (v1.05)   ok: found v1.10
    Checking for  DBD::mysql (any)     ok: found v2.1017

    failed: Client does not support authentication
    protocol requested by server; consider upgrading
    MySQL client at ../lib/Codestriker/DB/Database.pm
    line 58

    Can you help me out?  Thanks in advance.

    • David Sitsky

      David Sitsky - 2006-03-26

      Try upgrading your DBD::MySQL perl module, so that it supports the more recent authentication protocol required by your SQL server.

    • Manny

      Manny - 2006-04-04

      Thank you very much -- that was it.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks