Couldnt access application from browser

  • Krishna Priya

    Krishna Priya - 2007-09-18

    Hi ,

    I am using
    1.perl 5.8.8 version
    2. Ms SQL Server 2000
    3. IIS server 6
    4. codestriker-1.9.4-rc2

    And i ve created virtual directory for cgi-bin folder(codestriker) and html folder(codestrikerhtml) in IIS as specified in documentation.

    and when i tried to open the following URL

    http://localhost/codestriker/ it gives an error saying

    localhost - /codestriker/

    [To Parent Directory]    Tuesday, January 06, 2004  4:33 PM           22 .cvsignore


    Can any one help me how to open the application!!!!!!!!!!!
    Ant tables(data) are required in the database???

    I am new to perl and CGI
    I ve worked with apache and java

    Thanks in advance


    • David Sitsky

      David Sitsky - 2007-09-19

      Have you run the script successfully?  This is what creates the database tables, and creates the script.

    • Krishna Priya

      Krishna Priya - 2007-09-19

      Thanks for ur reply .

      when i submit this topic i didnt .But now i ran that script and is being created in cgi-bin. and when i open the below URL


      Its just displaying that page .functionlity is not working .Like links are not working.
      when i hover on the links ,in the status bar i can see the links as

      http://localhost/?action=create (for Create new Topic Link)
      http://localhost/?action=search (for Search  Link)   etc....

      and when i first open  http://localhost/codestriker/ link in browser
      i can see an alert with message
      'Oh oh..can't find codestriker.js,please check your apache config'

      what might be the problem???

      as i am new i dont know how to configure..
      can u please guide me.

      thanks in advance.


    • Krishna Priya

      Krishna Priya - 2007-10-30

      Hi david,
      I used the above link to install Active perl .It worked fine in Windows XP.And it got installed.

      IN windows 2000, i couldnt install packages(DBI,Template-Toolkit,Authen-SASL).Error i am getting while installing those packges is

      Error: Can't call method "list_files" on an undefined value at C:/Perl/site/lib/
      PPM/Archive/ line 31.
      According to this link
      its a bug in Active perl when used in Windows 2000 and it seems its not fixed.

      can u suggest me any other version of active perl which can be used with Windows2000 so that i can install ppm packges without fail.

      Thanks in advance.


      • David Sitsky

        David Sitsky - 2007-10-31

        What an annoying problem.. I can only suggest you install the latest, and try to install manually.


    • Krishna Priya

      Krishna Priya - 2007-10-31

      Thank u very much for your reply.
      I am new to perl .can you please tell me how to install manually??


      • David Sitsky

        David Sitsky - 2007-10-31

        Try using the ppm tool itself - it could be that a more recent version is available. 

    • Satyendra sen

      Satyendra sen - 2008-07-04

      I have some problem in codestriker, can u give me your mail add. then i will send u which activity i have done and what type of problem facing during installation.
      My mail add.



Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks