Trouble posting review: certificate expired

Sam Clark
2008-12-11
2013-06-03
  • Sam Clark

    Sam Clark - 2008-12-11

    Hi Guys,

    I'm trying to post a review using our production server and I'm getting:

    svn: OPTIONS of 'https://our/svn/repo': Server certificate verification failed: certificate has expired, issuer is not trusted (https://redcvs0).

    Is there a way to force codestriker to accept non-trusted certificates? In future we'd probably renew the certificate but I don't have access to our svn server machine.

     
    • David Sitsky

      David Sitsky - 2008-12-11

      This issue has come up before - have a search around, but here is a thread on this:

      https://sourceforge.net/forum/message.php?msg_id=4799185

       
    • Sam Clark

      Sam Clark - 2008-12-12

      I checked around but I'm getting a new error. I have permanently accepted the certificate and now I'm getting:

      Problem generating topic text:

      svn: Server sent unexpected return value (403 Forbidden) in response to OPTIONS request for 'https://our/svn/repo'.

      Codestriker will just use the credentials appended to the @valid_repositories entry correct? ('svn:https//our/svn/repo;user;password')

      I have tried svn list/info https://our/svn/repo --user=user --password=password at the command line and they have been successful. I have also tried navigating to the repo through a browser and entering my credentials there and then commenting out the "push @args, '--no-auth-cache'" lines in subversion.pm and rebuilding to no avail.

       
      • David Sitsky

        David Sitsky - 2008-12-12

        It might be worth typing in the svn command-line running as the same user as apache.  Subversion often requires some initial setup per-user for things to work correctly.

         
    • Sam Clark

      Sam Clark - 2008-12-12

      Alright, some success. I explicitly set the apache service to run as me and can now post reviews. Though I also restarted my computer so some of the other magic I tried may have kicked in.

      On to the next issue. Codestriker ocasionally complains that it can't find a specific revision in my repository. This seems to be a bit flaky in that I've posted back to back identical reviews with no configuration changes and had it fail only sometimes. The problem seems to be worse in firefox but that may be coincidence.

      My repo is served through https and most of the reviews I tried would have contained 25+ text-based (.c, .asm, .h) files and numerous other bins and IDE files (which wouldn't be reviewed). The machine running apache is kinda slow too. Could this be a network performance issue?

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks