I have several tests (unit tests and Spring framework integration tests). The tests work fine if I run them with “mvn surefire:test”. But there are test failure errors if I run “mvn cobertura:cobertura”. In the log, I can see it past instrument and failed at surefire. The errors are on the Spring integration tests as following


org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'xxx' defined in class path resource [applicationContext.xml]: Error setting property values; nested exception is org.springframework.beans.PropertyAccessExceptionsException: PropertyAccessExceptionsException (1 errors); nested propertyAccessExceptions are: [org.springframework.beans.TypeMismatchException: Failed to convert property value of type [$Proxy1] to required type [xxx] for property 'xxx']

PropertyAccessExceptionsException (1 errors)


This is what I don’t understand - surefire are called in both cases. How come it worked in the first case but failed in cobertura?


I use maven 2.0.4 and JDK 1.5.0. Thanks in advance.