Menu

#56 unified naming approach for functions setting callbacks

Upstream submission
closed-fixed
None
5
2018-01-12
2018-01-10
No

There are the following functions setting callbacks

CMP_CTX_set_msg_transfer()
CMP_CTX_set_certConf_callback()
CMP_CTX_set_error_callback()
CMP_CTX_set_debug_callback()

At least one of them ;-) needs to be renamed to match the logic of the others.

OpenSSL is using mostly "cb" when getting/setting the callback functions, rarely expanded to "cb_func", so maybe we should also shorten that?

E.g.:
EVP_PKEY_set_cb()
X509_STORE_set_verify_cb_func()
X509_STORE_get_verify_cb()
X509_STORE_CTX_get_verify_cb()
X509_STORE_CTX_set_verify_cb()

Discussion

  • Martin Peylo

    Martin Peylo - 2018-01-10
    • summary: univied naming approach for functions setting callbacks --> unified naming approach for functions setting callbacks
     
  • David von Oheimb

    • status: open --> closed-fixed
    • assigned_to: David von Oheimb
     

Log in to post a comment.