Can't manage to restore image

  • Eduardo Escobar

    Eduardo Escobar - 2013-06-14

    Hi folks,

    I'm trying to restore a disk image using Clonezilla. This image is actually uncompressed in /media/image directory and it has the following files:

    disk sda1.ext3-ptcl-img.lzo.aa sda-mbr
    Info-dmi.txt sda6.ext3-ptcl-img.lzo.aa sda-pt.parted
    Info-lshw.txt sda7.ext3-ptcl-img.lzo.aa sda-pt.sf
    Info-lspci.txt sda7.ext3-ptcl-img.lzo.ab
    Info-packages.txt sda-chs.sf
    parts sda-hidden-data-after-mbr

    The following are also parts of my scenario:

    • The mentioned source image is in computer A (Debian), NSF server enabled, sharing /media/image directory

    • Computer B has a 250Gb SATA hard drive which is the one i want to write the image to (it's actually not formatted and it has several partitions and filesystems)

    • I'm using Live USB Clonezilla 2.1.1 stable version.

    • NFS server was tested from within USB booted Clonezilla (i was able to mount Computer's A shared directory /media/image into Computer's B, using command line)

    The procedure i'm following is:

    1. Boot up Clonezilla in default mode
    2. Select default language and keyboard configuration
    3. Start up Clonezilla (Start_Clonezilla)
    4. Select device-image option
    5. Select nfs_server option
    6. Select DHCP option
    7. Select nfs v2, v3
    8. Input Computer's A IP (
    9. Input Computer's A shared dir (/media/image)
    10. Press "Enter" to continue
    11. Select "Beginner" mode

    At this stage, i can't find the option "restoredisk". There are just "savedisk" and "saveparts" options which i belive won't help me in achieving what i want.

    I'm new at Clonezilla and maybe i'm missing something.

    Any help would be kindly appreciated.

  • Norman C-B-C

    Norman C-B-C - 2013-06-14

    I too have this issue ... I am using clonezilla-live-2.1.1-25-amd64.iso

    ... and by the time you get past the DHCP stage you only get 3 options :


    there is no intermediate step to select between savedisk and restoredisk

    Last edit: Norman C-B-C 2013-06-14
  • Norman C-B-C

    Norman C-B-C - 2013-06-14

    Same thing happens with the clonezilla-live-20130429-raring-amd64.iso

    I'm doing this on an HP XW6400 XEON Workstation.

  • Eduardo Escobar

    Eduardo Escobar - 2013-06-14

    I found out that the image directory should be a sub-directory of the NFS shared directory:

    NFS Shared dir on Computer 1: /media
    Image dir: /media/image

    After modifying /etc/exports , restarting NFS server and rebooting Clonezilla (on step 9 i inputted: /media) i finnaly got the restoredisk option enabled.

  • Steven Shiau

    Steven Shiau - 2013-06-16

    When you run "drblpush -i", it warns you not to use /media, /tmp... directories (they are tmpfs) as image repository. So...


  • drsbaitso

    drsbaitso - 2015-04-15

    I know this is old but I just ran into this.

    I had to have the image not in the root share. For example I was sharing \servername\share and then the folder 2015-04-15.... was under there. That didn't work for some reason so if I shared \servername\share and then have a folder underneath that, it worked fine.

    Old : \servername\share\2015-04-15...
    New : \servername\share\images\2015-04-15...

    I think Clonezilla boogers out when it tries to load an image from the share itself. Maybe I'm wrong but that's the only way it worked to restore the images in my case.


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks