Weird effect after using Clonzilla to image XP disk- USB 3 posrts no longer work

Help
2014-01-11
2014-01-16
  • Mister Creeky

    Mister Creeky - 2014-01-11

    This has been repeated on at least 5 new systems using Asus P8H77 Mobo, and another Mobo using H77 chip set - i3 CPU, 4GB RAM and UDB 3.0 ports, XPSP3 32 bit. The systems starts out with 2 new drives installed, all running latest BIOS firmware on Mobo. Everything on the OS installs, drivers install, all hardware - including USB 3.0 ports work fine. The second disk is partioned and formatted NTFS, works fine. It is all perfect up to this point.

    Now we Clonezilla (via USB LiveImage) the first drive to the second drive. We can do it drive to drive or drive to image - and put the image ion the second drive. Either method. Everything works, or so it seems. We can unplug the original master drive and have only the cloned drive in the machine and everything works, except for the USB 3.0 ports.

    Now we plug in the original master disk and boot up from it - and again everything works except USB 3.0 ports. We reinstall Intel / USB 3 drivers, etc. to no avail. Checked BIOS and it doesn't appear anything is changed there.

    The only clue is that booting up either the Master drive OR the cloned drive immediatlye after Clonzilla made the clone - XP goes thru its "Found New Hardware" process, and then tells us that "The New Hardware is Ready to Use".

    The USB 3.0 are working but only at 2.0 speed. And this ONLY happens after using Clonezilla. The spooky part is the Master disk from which we made the image now only runs USB ports at 2.0 speed, and ONLY after Clonzilla was used.

    Latest version of Clonezilla and earlier versions, and the only time we see this is on 'H77 mobo's, repeatedly.

    Any idea on how to get USB 3.0 speed back? Again, tried uninstalling drivers, reinstalling, etc. won't get USB 3.0 back. Install XP SP3 fresh from a fresh formatted drive, and we get USB 3.0 back.

    Again, all this happens only after using Clonezilla....

    "Help?"

     
  • Steven Shiau

    Steven Shiau - 2014-01-12

    Did you mean after using Clonezilla live to clone/restore the system, the cloned/restored system boots fine, but USB 3.0 is not supported in the restored/cloned OS?
    In this case, it's really weird... Since it's cloned/restored, the OS should take over all the controls... No idea how Clonezilla live affects this.
    BTW, did you upgrade your BIOS firmware? Maybe it helps.

    Steven.

     
  • Mister Creeky

    Mister Creeky - 2014-01-12

    Yes, Steven. We've tried updating BIOS firmware. Yes, after cloning to another drive with CZ, the system will boot up OK, then XP goes thru its routine of "found new hardware", then it tells us it found the new disk and hardware ready to use. All will be OK except USB 3.0 refuses to start.

    This will happen on any number of Asus P8H77 Mobo as well as a Corvalent QH77 Mobo (both have i3 CPU's and 'H77 chipsets). These are industrial machine controllers.

    Every other system we've tried is fine, Clonezilla works like a champ.

    The only thing we can think of is something on these UEFI Bios's is somehow keeping track of the last disk serial number the system was booted from ?? When XP / BIOS sees a different boot drive, it must cause the scan for new hardware?

    The trouble is when we boot up from the cloned drive, and then go back to boot up from the orginal master drive - then the master drive won't have working USB 3.0 either.

    The device manager doesn't even show the USB 3.0 device listed.

    Unloading / reloading the XP drivers has no effect, its like suddenly the Mobo has no USB 3.0 capability at all.

    The only cure we've found is to re-load XP from scractch. reload all drivers, and then the system runs normally again.

    My thinking is: When CZ clones a drive, it should not disturb any single bit on the source drive, and should not make any change to BIOS setting, correct?

    -John

     
  • Steven Shiau

    Steven Shiau - 2014-01-15

    "When CZ clones a drive, it should not disturb any single bit on the source drive" -> Yes. Unless there are bugs...
    "and should not make any change to BIOS setting" -> For uEFi, it will check if the boot entry for the restored OS exists or not. If not, it will be added. Therefore I have to say in this condition the uEFI BIOS, especially the boot entry, will be changed.

    Steven.

     
  • Mister Creeky

    Mister Creeky - 2014-01-16

    I will look to see what might be going on in the Bios...

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks