TFTP file location

  • EricG1793

    EricG1793 - 2014-05-02

    I'm having issues with PXE clients obtaining IP addresses from the Clonezilla server in my network with VLANs, as mentioned here:

    I've since read that Spanning Tree creates an issue with PXE booting. Sure enough, the ports I added to my new VLAN somehow were subject to the RSTP protocol, which I removed them from (made the ports Edge). Still no go.

    My latest idea is to use the switch's (Juniper EX3300, part of a virtual chassis but all ports in question are in 1 switch) internal DHCP server to give clients IP addresses of with a mask. The scope options even provide a location to specify boot servers and boot file names. I figured I'd specify the Clonezilla server as the boot server, but I have no idea what to put for the boot file. Do I need to provide the full path, or just the name of the file? If I give it any sort of name or path, the client says "TFTP error - file not found." If I do not specify a file, it complains accordingly.

    One of the files I tried specifying is initrd-pxe.3.12-1-amd64.img. Is this correct? I've since shut everything down, but looking back in the DHCP config, it seems I made a typo, so maybe it should work but it's just me being an id10t. ;)

    Any ideas?

  • EricG1793

    EricG1793 - 2014-05-03

    Short version: What do I need to type in the "boot file" field of a non-Clonezilla DHCP server to make PXE clients boot off the Clonezilla server?

    On further research, it looks like I should be specifying /tftpboot/nbi_img/pxelinux.0. Or should it be /tftpboot/nbi_img/pxelinux.cfg/default? Or something else?

  • Steven Shiau

    Steven Shiau - 2014-05-03

    It depends on your tftpd config.
    On DRBL (Clonezilla SE) server, the default settings of tftpd-hpa is:
    cat /etc/default/tftpd-hpa
    TFTP_OPTIONS="--secure --ipv4"



Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks