Lite problem to run clonezilla in aitomatic mode

2014-07-31
2014-08-17
  • Patrick d'Emmabuntüs

    Hi Steven,

    I am Patrick of Emmabuntüs : https://sourceforge.net/projects/emmabuntus we see you in RMLL 2014 in Montpellier.

    Now I try to use Clonezilla in automatic mode for 3 days, and I have some problems :

    • Not possible to mount USB sdb2 on /home/partimag
    • Not possible to run ocs-sr in the config of grub

    If use theses command on line command in clonezilla all are OK :
    - sudo mount /dev/sdb2 /home/partimag/
    - sudo /usr/sbin/ocs-sr -g auto -e1 auto -e2 -c -r -j2 -k2 -r -p true restoredisk img-emma sda

    But when I try to use this command on grub config file, the /home/partimagis not mount, and if I mount on command line, after the ocs-sr not work, and I have a lot off mesages on screen and it is not possible to read, because they are display very quickly :(

    My config line is :

    linux /debian1/vmlinuz ro root=UUID=D7FF-0D81 live-media-path=/debian1 boot=live config noswap edd=on nomodeset ocs_prerun="mount /dev/sdb2 /home/partimag/" ocs_live_run="ocs-sr" ocs_live_extra_param="-g auto -e1 auto -e2 -c -r -j2 -k2 -r -p true restoredisk img-emma sda" ocs_live_batch=no vga=788 ip=frommedia nosplash i915.blacklist=yes radeonhd.blacklist=yes nouveau.blacklist=yes vmwgfx.blacklist=yes boot=live username=user config quiet locales=fr_FR.UTF-8 keyboard-layouts=fr vmwgfx.enable_fbdev=no
    initrd /debian1/initrd.img

    or this :

    linux /debian1/vmlinuz ro root=UUID=D7FF-0D81 live-media-path=/debian1 boot=live config noswap edd=on nomodeset ocs_prerun="mount /dev/sdb2 /home/partimag/" ocs_live_run="ocs-sr -g auto -e1 auto -e2 -c -r -j2 -k2 -r -p true restoredisk img-emma sda" ocs_live_extra_param="" ocs_live_batch=no vga=788 ip=frommedia nosplash i915.blacklist=yes radeonhd.blacklist=yes nouveau.blacklist=yes vmwgfx.blacklist=yes boot=live username=user config quiet locales=fr_FR.UTF-8 keyboard-layouts=fr vmwgfx.enable_fbdev=no
    initrd /debian1/initrd.img

    I have try to use this option ocs_debug=yes but the script don't start !

    I have try to put sudo on config line on ocs_prerun and ocs_live_run, but they don't work.

    My orignal line which works fine in interactive mode is :

    linux /debian1/vmlinuz ro root=UUID=D7FF-0D81 live-media-path=/debian1 boot=live config noswap edd=on nomodeset ocs_live_run="ocs-live-general" ocs_live_extra_param="" ocs_live_batch=no vga=788 ip=frommedia nosplash i915.blacklist=yes radeonhd.blacklist=yes nouveau.blacklist=yes vmwgfx.blacklist=yes boot=live username=user config quiet locales=fr_FR.UTF-8 keyboard-layouts=fr vmwgfx.enable_fbdev=no
    initrd /debian1/initrd.img

    Thank you in advance for your help.

    Best regards

    Patrick

     
  • Steven Shiau

    Steven Shiau - 2014-08-07

    Hi Patrick,
    It was nice to meet you in RMLL. Sorry for the late response because I had a vacation 7/21-31 and there are so many things to do after that.
    As for your issues, if you meant you use the grub on the hard drive, which version of grub are you using?
    Some older version of grub you need to use back slash "\" for the boot parameters, as described here:
    http://clonezilla.org/livehd.php
    i.e. something like:
    ocs_prerun=\"mount /dev/sdb2 /home/partimag/\"
    Please let me know if it works or not.
    Thanks.

    Steven.

     
  • Steven Shiau

    Steven Shiau - 2014-08-17

    Hi Patrick,
    Great! It's nice to know Clonezilla works for you now.
    Thanks for sharing Multisystem with us.

    Steven.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks