Jens Holze - 2014-01-07

Hi there!

I've got a problem with booting clonezilla live via PXE. The initial part works but after the kernel ran it's messages and the network interfaces are activated the boot fails because it seems that our dhcp server takes longer than 15 seconds to answer the request (takes up to 30s sometimes for the first part, not sure why). Yet he does answer it, if I run 'ipconfig eth1' after it has failed the interfaces seems to have the ip.
is there a way to extend the timeout to more than 15 seconds? There are two interfaces yet only one is connected. I'm using version 2.2.0-16.

Also, I tried to configure the network with a static ip by adding the ip option in the pxelinux.cfg but that seems to be ignored. It reads

APPEND initrd=clonezilla/initrd.img boot=live live-config noswap nolocales edd=on nomodeset ocs_live_run="ocs-live-general" ocs_live_extra_param="" ocs_live_keymap="/usr/share/keymaps/i386/qwertz/de-latin1-nodeadkeys.kmap.gz" ocs_live_batch="no" ocs_lang="en_US.UTF-8" ocs_daemonon="ssh" vga=788 nosplash  ip=eth1:xxx.xxx.xxx.xxx:255.255.255.0:yyy.yyy.yyy.yyy fetch=http://yyy.yyy.yyy.yyy/ubuntu10_4/clonezilla/live/filesystem.squashfs

yet DHCP timeout still occurs.

Any help would be appreciated, thanks.