#33 ntfsclone not working with Debian lenny with arch. amd64

closed-fixed
None
5
2009-06-23
2009-03-19
No

DRBL/Clonezilla version: unstable (in order to have Lenny recognized by drblsrv -i).

DRBL server OS: Debian GNU/Linux 5.0 (lenny) arch: amd64.

ntfsclone shipped with Clonezilla doesn't work in this configuration and doesn't want to start with a "No such file or directory" error message.

Tryed to use ntfsprogs shipped with Debian (by installing package and by copying files to correct places (/opt/drbl/sbin and /opt/drbl/bin). ntfsclone os now working, but Clonezilla isn't able to use them (error message is about the "-V" parameter, which ntfsclone 2.0 doesn't understand).

Maybe ntfsclone should be installed by the OS packager *and* scripts should be adapted to work with all (current) versions of ntfsprogs.

Regards,
Olivier.

Discussion

  • Steven Shiau

    Steven Shiau - 2009-03-19
    • assigned_to: nobody --> steven_shiau
     
  • Steven Shiau

    Steven Shiau - 2009-03-20

    Thanks for this bug report.
    Could you try:
    1. Upgrade your package clonezilla to be clonezilla (2.3.2-70) in the unstable branch. A new mechanism was added in this version so that "-V" will be checked if available before it it run.
    2. mv /opt/drbl/sbin/ntfsclone /opt/drbl/sbin/ntfsclone.backup on your DRBL server.
    3. Install the ntfsprogs from debian 5.0 if it's not installed.
    Then you can do a normal clone. It should work. Please let us know the results.

    Steven.

     
  • Steven Shiau

    Steven Shiau - 2009-03-20

    BTW, could you please run:
    ldd /opt/drbl/sbin/ntfsclone
    both on your DRBL server and client, then post the results ?
    Thanks.

     
  • Steven Shiau

    Steven Shiau - 2009-03-20

    OK, found the bug why ntfsclone won't run on drbl client.
    You can manually fix it by running the following command on your server:
    sudo cp -a /emul /tftpboot/node_root/

    We will fix this in the next release of DRBL.
    Thanks again.

    Steven.

     
  • Steven Shiau

    Steven Shiau - 2009-03-20
    • status: open --> open-accepted
     
  • Olivier Korn

    Olivier Korn - 2009-03-20

    Hi Steven,

    I can't test what you're asking before next week (not before 2009-03-27). But I did resolvethe problem by 1) replacing ntfsclone from drbl-ntfsprog package by ntfsclone from Debian distribution package and 2) by editing script and removing "-V" parameter. All worked perfectly after that.

    So I guess that your solution is already correct.

    Tell me if you still want me to do the tests next week.

    Thanks a lot.
    Olivier.

     
  • Olivier Korn

    Olivier Korn - 2009-03-27

    Tested successfully. Version 1.9.3-38 is perfectly working.

    Thanks a lot.

     
  • Steven Shiau

    Steven Shiau - 2009-03-27
    • status: open-accepted --> closed-accepted
     
  • Steven Shiau

    Steven Shiau - 2009-03-27

    Fixed in DRBL 1.9.3-38.

     
  • Steven Shiau

    Steven Shiau - 2009-06-23
    • status: closed-accepted --> closed-fixed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks