#430 OSX: CPPFLAGS get messed up

build problems
closed
clisp (525)
5
2007-12-13
2007-11-26
No

Is this something silly wrong that I am doing?

configure: loading cache ../config.cache
configure: error: `CPPFLAGS' has changed since the previous run:
configure: former value: -I /usr/local/include
configure: current value: -I /usr/local/include -I/usr/local/include

Discussion

  • Christopher Stacy

    build session

     
  • Sam Steingold

    Sam Steingold - 2007-11-26

    Logged In: YES
    user_id=5735
    Originator: NO

    could you please attach your generated Makefile too?
    thanks!

     
  • Sam Steingold

    Sam Steingold - 2007-11-28

    Logged In: YES
    user_id=5735
    Originator: NO

    this is the standard request for more information.
    1. what is your platform?
    ("uname -a" on a Unix system)
    compiler version? libc (on Linux)?
    2. where did you get the sources? when?
    (absolute dates are prefered over the relative ones)
    3. how did you build CLISP? (what command, options &c)
    please do a clean build (remove your build directory and
    build CLISP with "./configure --build build" or at least
    do a "make distclean" before "make")
    4. if you are using pre-built binaries, the problem is likely
    to be in the incompatibilities between the platform on which
    the binary was built and yours;
    please try compiling the sources.
    5. what is the output of (lisp-implementation-version)?
    6. what is the value of *features*?
    7. please supply the full output (copy and paste)
    of all the error messages.
    If you cannot build CLISP, you can obviously skip 5 and 6,
    but then you should provide more information in 1.
    please see <http://clisp.cons.org/clisp.html#bugs>
    for more information.
    Thanks.

    PS. This bug report is now marked "pending"
    and will auto-close unless you respond
    (in which case it will auto-re-open).

     
  • Sam Steingold

    Sam Steingold - 2007-11-28
    • status: open --> pending
     
  • Sam Steingold

    Sam Steingold - 2007-11-28

    Logged In: YES
    user_id=5735
    Originator: NO

    This bug report is now marked "pending" and will auto-close unless you respond (in which case it will auto-re-open).

     
  • El cepi

    El cepi - 2007-11-30

    Logged In: YES
    user_id=1006669
    Originator: NO

    This is a **Known** problem on MacOSX. What append is that file config.cache gets rewritten causing make to complain. The problem is solved by removing file config.cache and running make again. Hope this help.

     
  • SourceForge Robot

    • status: pending --> closed
     
  • SourceForge Robot

    Logged In: YES
    user_id=1312539
    Originator: NO

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks