#1 Fails to compile on HPUX 10.20 9000/785

segfault
closed-wont-fix
clisp (525)
5
2000-04-04
2000-02-11
Anonymous
No

Attempted to compile with gcc 2.95 and rolled back
to 2.7.2. Results were:

installing es.gmo as ../../locale/es/LC_MESSAGES/clisp.mo
make[1]: Leaving directory `/archive/packages/clisp-1999-07-22/src/gettext/po'
gcc -O -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type -fomit-frame-pointer -O2 -fno-strength-reduce -DUNICODE -DDYNAMIC_FFI -x none spvw.o spvwtabf.o spvwtabs.o spvwtabo.o eval.o control.o encoding.o pathname.o stream.o socket.o io.o array.o hashtabl.o list.o package.o record.o sequence.o charstrg.o debug.o error.o misc.o time.o predtype.o symbol.o lisparit.o foreign.o unixaux.o arihppa.o gmalloc.o modules.o libsigsegv.a libintl.a libreadline.a libavcall.a libcallback.a -ltermcap -o lisp.run
sync
./lisp.run -m 750KW -B . -N locale -Efile ISO-8859-1 -norc -x "(load \"init.lsp\") (sys::%saveinitmem) (exit)"
/bin/sh: 5161 Bus error(coredump)
make: *** [interpreted.mem] Error 138

--
friedman@emax.ca

Discussion

  • Sam Steingold

    Sam Steingold - 2000-02-11
    • assigned_to: nobody --> haible
    • status: Error - status not found --> open
     
  • Bruno Haible

    Bruno Haible - 2000-04-04
    • status: open --> closed-wont-fix
     
  • Bruno Haible

    Bruno Haible - 2000-04-04

    I can reproduce it. The \"make\" run crashes. But when I execute the commands

    ./lisp.run -m 750KW -B . -N locale -Efile ISO-8859-1 -norc -x \"(load \"init.lsp\") (sys::%saveinitmem) (exit)\"
    mv lispimag.mem interpreted.mem

    by hand, it works. Afterwards I rerun \"make\". Same thing two more times. Finally the binaries are completely built.

    It is not clear to me how the command can fail when run from \"make\" but work when run from bash. I don\'t see what I could fix there. Especially since you say that the problem doesn\'t occur with gcc-2.7.2 built lisp.run.

     

Log in to post a comment.