Toggle Navigation Pane

Help
2012-05-16
2014-04-06
  • raffnixpert

    raffnixpert - 2012-05-16

    I read the solution in https://sourceforge.net/projects/classicshell/forums/f
    orum/1049755/topic/3932317
    and tried to realize the sendkeys script on my
    system. But it does not work.

    Knowing nearly nothing about javascript I would like to ask helpers to have a
    look at my attached screenshots and guide me to a functioning custon toolbar
    button for toggling the Win7 ClassicExplorer Navigation Pane. It is really
    essential to me because I use my 1050x1680 22 inch LED display in Portrait
    orientation in order to display a complete Word page on the screen without
    having to scroll, but of course with considerable drawbacks in Win7 Explorer.


     
  • raffnixpert

    raffnixpert - 2012-05-17

    The second screenshot in the first posting should have rather been the
    following one because (if my poor understanding is correct) it is not the
    layout of the toolbar that matters for the script but the submenus under the
    "Organize" button.

     
  • raffnixpert

    raffnixpert - 2012-05-31

    There is a recurring wish expressed in the SourceForge.net Forums to be able
    to toggle the Win7 explorer navigation pane - the last time on 2012-05-21
    under Open Discussion as Feature Request. https://sourceforge.net/projects/cl
    assicshell/forums/forum/1049755/topic/3932317
    was referenced there for
    solution.

    In my present thread here I indicated that this solution has not worked in my
    case. Did I present this problem in the wrong forum - because there has no
    answer been given so far? It would be extremely important to me to get this
    sendkeys procedure working because it is mandatory to me to use my LED display
    in Portrait orientation and with that orientation and the navigation pane
    present I can only see name, date and type on the right explorer side i.e. no
    file size without resetting the column widths!

    I think it could be very useful for users with the same problem if in addition
    to the above reference they would find here a second example with a different
    "Command" line for the CustomButton. I have the naïve idea that it must be
    rather easy for you expert helpers to write down the command that pertains to
    the diagram of my Win7 explorer in my posting #2 (the German language does not
    present any difficulty does it?)

     
  • Ivo Beltchev

    Ivo Beltchev - 2012-05-31

    Sorry for not responding. I do not have a solution to this, aside from the
    sendkeys that was suggested by somebody in another forum. AFAIK the solution
    depends on specific keys, which are different from langugage to language. Now
    that you mention German, that's a very likely reason why it is not working for
    you.

    I have not tried this solution myself and can't vouch how well it works, and
    can't offer a solution how exactly to change the script to work for other
    languages.

     
  • Anonymous - 2012-05-31

    I gave another solution independent of SendKeys in that same thread you linked
    to, which is to modify the registry to put the 'Navigation pane' button
    directly on the Explorer command bar. Looks like you did not read the thread
    you linked to in its entirety. If you want it done with an easy GUI way, use
    this: http://www.nirsoft.net/utils/custom_explorer_toolbar.html to add the button.

     
  • raffnixpert

    raffnixpert - 2012-06-05

    Thanks a lot, xpclient, for referring me to your Explorer command bar
    solution. I had indeed noticed it in my referenced link but considered it too
    complicated for me at that time.

    When you gave me the nirsoft link to a GUI solution of your custom explorer
    toolbar button I decided to muster the courage to give it a try. At first I
    started CustomExplorerToolbar.exe in my Admin account with partial success:
    The NavPane Toolbar Button did only show up for a folder after one of its
    subordinate folders had been selected before. Any folder selection on the same
    or superimposed level would cause this button to disappear again.

    When I started CustomExplorerToolbar.exe as administrator in a user account it
    produced the button rather eratically if at all.

    So I went back to your registry tweak in https://sourceforge.net/projects/cla
    ssicshell/forums/forum/1049755/topic/3932317
    and decided to try to follow
    the steps you indicated there although I am not on safe ground on such matters
    as dealing with taking ownership or granting admin rights. I did it only with
    respect to one of the six folder types i.e. HKLM\SOFTWARE\Microsoft\Windows\ CurrentVersion\Explorer\FolderTypes{5c4f28b5-f869-4e84-8e60-f11db97c5cc7}.
    This time it did work reliably. Hurra.

    The only question remaining is whether I should undo the changes to ownership
    and admin rights for the registry keys concerned. Please be so kind as to
    answer that last question and many thanks again for your help.



    My system:
    Intel Core i3 540, 8 GB RAM, 2 SATA-HDD with 640 GB each, Win7 64-Bit with
    Classic Shell by Ivo Beltchev, Kaspersky Internet Security 2012, WinPatrol
    PLUS, Firefox 12 with NoScript, Thunderbird 12 (POP3)

     
  • raffnixpert

    raffnixpert - 2012-06-05

    There was a highly disfiguring error in my last posting. I badly miss an edit
    function in this forum so that the wrong sentence would not need to remain in
    place. As it is, it only remains for me to supply the correct version of the
    last sentence in para 2 of my previous posting (#6) in hindsight:

    "Any folder selection on the same or subordinate level would cause this
    button to disappear again."

     
  • Anonymous - 2012-06-05

    You can set the permissions to what they were but no need I think. As long as
    you have added it for both cases - Items selected and Items not selected and
    for the 6 core folder templates - Generic, Documents, Music, Videos, Pictures
    and whatever, it should always show up on the Command bar. :)

     
  • raffnixpert

    raffnixpert - 2012-06-15

    I followed your advice and did your registry tweak for all of the 6 core
    folder templates, but the NavPane Toolbar Button appeared to show up only for
    folders optimized wrt General Items as shown in the following screenshot
    (sorry for the German language there):

    Unfortunately the appearance of the button is not 100 percent reliable over
    time but is still a useful expedient for my purposes. A drawback however is
    the fact that the button will not show up when clicking on a folder in the
    file pane. Here a functioning ClassicExplorer custom toolbar button for
    toggling the Win7 ClassicExplorer Navigation Pane would be clearly superior
    since it would be available under all circumstances. But as I said in my first
    posting it does not work for me.

     
  • Anonymous - 2012-06-15

    Merging this should definitely make it work for Generic folder type whether
    anything is selected or not and should work when either folder pane or file
    pane is active (Edit the commands as you wish of course or merge as it is):

    Windows Registry Editor Version 5.00

    @="Windows.navpane;Windows.previewpane;Windows.readingpane;Windows.selectall;W
    indows.removeproperties"

    @="Windows.navpane;Windows.previewpane;Windows.readingpane;Windows.SelectAll"

     
  • xpclient

    xpclient - 2012-06-15

    If you want it for all folder types and also add buttons for all other panes,
    merge this reg:
    http://sdrv.ms/MaiuDn Works for me on Windows 7 and
    Windows 8 for all folder types. It should merge successfully without errors.
    If you get errors while merging, it means you haven't taken ownership and
    admin permissions of all child objects correctly.

     
  • raffnixpert

    raffnixpert - 2012-06-27

    merge this reg: http://sdrv.ms/MaiuDn Works for me
    on Windows 7 and Windows 8 for all folder types.

    This is great! Thank you xpclient. Now I have at least a workable solution
    (NavPane Toolbar Button also in the file pane) with more (hopefully) still to
    come once I have fully understood ownership and admin permissions. For
    although I have studied these things for over a week now I still do not get
    the NavPane Toolbar Button for folders that are optimized i.a. for pictures
    and documents.

    I got two error messages, one upon changing ownership and permissions and the
    other one when trying to merge your reg-file referenced in your #11. I hope I
    will be able to sort out the first one by myself. As concerns the reg merging
    I got the following message (even as Administrator in Safe Mode):

    I will try to translate this into English:
    “C:\Users\<username>\Desktop\Command Bar Actions for all Folder Typers.reg
    cannot be imported: Not all data could be entered into the system registry.
    Some keys are used by the system or other processes.”

    What could be the reason for this message? Is the storage location of the reg
    file to be merged significant?

     
  • xpclient

    xpclient - 2012-06-27

    The error is because the registry key ownership and permissions are not being
    fully set for child objects. Okay I will give step by step instructions.

    1. Open Regedit.
    2. Go to the key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes
    3. Right click it and select Permissions.
    4. Click Advanced button.
    5. Ownership must be taken before granting admin permissions. On the Owner tab, change the owner to "Administrators" group (note the Group called Administrators, not "Administrator").
    6. Make sure to check the box "Replace owner on subcontainers and objects" and click Apply.
    7. Now on the Permissions tab, give "Full control" permissions to the "Administrators" group and again check the box "Replace permission entries on all child objects".
    8. Now click OK twice to close the Security properties and try merging the reg file. You should not ideally get any errors, everything should be merged if you have taken the permissions correctly.
    9. I improved the reg file a little bit. Download the new one here: http://sdrv.ms/MU7Sww . I tested it on Windows 7 SP1 x64 and Windows 8 Release Preview x64 and it's certainly working (Windows 8 only works if you disable the Ribbon using Ribbon Disabler).
     
  • xpclient

    xpclient - 2012-06-27

    Here's the proof:

     
  • xpclient

    xpclient - 2012-06-30

    Hey raffnixpert, were you able to finally get that toggle 'Navigation pane'
    button for all folder types? Otherwise, I have found another tool that may be
    a simpler way for you to get the job done: http://winaero.com/comment.php?com
    ment.news.16

     
  • raffnixpert

    raffnixpert - 2012-07-03

    Owing to your step-by-step instructions on how to set registry key ownership
    and permissions correctly I was able to perform this task without error
    messages this time. Thank you very much for this valuable lesson.

    I then merged your new reg file, again without any error message. I am not
    aware, though, where the difference to the old reg files are; perhaps some
    buttons that I do not urgently need. This multitude of buttons is certainly
    nice to have if you have got a wide screen display operated in normal
    landscape orientation. In my case with portrait orientation (cf. my posting

    1) too many buttons are rather disadvantageous because sometimes I would even

    have to open a drop-down list in order to find the “Navigation pane” button,
    which is the most important one for me besides the “New folder” button.

    The functionality is perfect at volumes/folders optimized for General Items
    and, as far as I could evaluate up to now, for documents. But as concerns
    music, pictures and video, the behaviour with respect to the presence or
    absence of the navpane button is somwhat enigmatic to me irrespective of
    whether the folders are in My Computer or in other volumes than (C:).

    So I think I will try Explorer Toolbar Editor linked in your #15 and will
    revert to your great reg file if the tool proves inadequate for my purposes.
    What puzzles me a bit is that your reg file requires registry key ownership
    and permissions to be set whereas the tool obviously can do without such
    settings.

     
  • xpclient

    xpclient - 2012-07-03

    Well the tool may be silently taking ownership and admin permissions or it may
    be operating with another privilege level like SYSTEM. You can edit the reg
    file to remove the unnecessary commands you don't want and add any new ones
    separated by semicolons. A list of all possible commands is at: HKEY_LOCAL_MAC
    HINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\CommandStore\shell .
    The reg file also clearly mentions the "Canonical name" or folder template for
    which the commands are.

     
  • raffnixpert

    raffnixpert - 2012-07-03

    Yes, I see. I think this rounds the subject off nicely and I now have
    sufficient info at hand to play with. Thank you xpclient.

     
  • raffnixpert

    raffnixpert - 2012-07-06

    I have to come back once more to the subject in order to correct my statements
    in #16 as follows: The reg file works perfectly in my admin account for all
    types of folders and volumes, even for "My Computer". The NavPane button is
    always present.

    The minor deviations described in #16 only occur in the user accounts where
    the NavPane button ist also missing for "My Computer".

     
  • raffnixpert

    raffnixpert - 2012-07-13

    Hello xpclient,

    in #19 I wrote

    The minor deviations described in #16 only occur in the user accounts where
    the NavPane button ist also missing for "My Computer".

    Do you have a proposal on ownership and permissions in addition to the group
    of administrators as stipulated in paras 5 and 7 in your #13 (quoted below for
    convenience) that could solve the deviations in may user accounts?

    1. Ownership must be taken before granting admin permissions. On the Owner
      tab, change the owner to "Administrators" group (note the Group called
      Administrators, not "Administrator"). 6. Make sure to check the box "Replace
      owner on subcontainers and objects" and click Apply. 7. Now on the Permissions
      tab, give "Full control" permissions to the "Administrators" group and again
      check the box "Replace permission entries on all child objects".

    I assume there is a simple answer to this. Otherwise, I would not want to
    prolong this thread just for myself.

     
  • xpclient

    xpclient - 2012-07-13

    Not understanding what you are asking. You want the 'Navigation pane' button
    to also appear for (My) Computer? Or you are not getting the navigation pane
    button for other folder types? If the account is not from Administrators
    group, all registry related operations must be done as administrator. Right
    click Regedit and use "Run as" to do them as administrator.

     
  • raffnixpert

    raffnixpert - 2012-07-17

    If the account is not from Administrators group, all registry related
    operations must be done as administrator.

    I cannot remember exactly under which account and context I had set key
    ownership and permissions. So I repeated your step-by-step instructions of
    your #13 in my user account making sure I was running regedit as
    Administrator.

    This time, in contrast to the situation before, the navpane toolbar button for
    “My Music” and “My Videos” is always present in Classic Explorer irrespective
    of what items I click and in what sequence.

    But when I open My Computer - e.g. with Win+E - the navpane toolbar button
    appears in the administrator account whereas it is missing in the user
    account. How can I get it in the user account too?

     
  • xpclient

    xpclient - 2012-07-17

    Dunno how you got the Navigation pane button to appear for (My) Computer. I
    would like to do that myself. :)

     
  • raffnixpert

    raffnixpert - 2012-07-17

    I installed and configured Explorer Toolbar Editor, which you proposed in your

    15. Now I am uncertain about two things:

    Whether or not I had undone the registry changes made before in accordance
    with your regfile given in #11 for all folder types and whether the navpane
    button in My Computer (Admin Account) appeared already before or only after
    installing Explorer Toolbar Editor. Anyway, it is there as you can see here
    (first and only item in the drop down list):

    By the way, I did not become aware of any differences to the situation before
    installing the tool. In fact, I unfortunately did not look out for such
    differences. Otherwise I might have perceived a change in My Computer if it
    had occurred.

     
  • xpclient

    xpclient - 2014-04-06

    Good news. The latest Classic Shell 4.0.6 has a built-in button now to toggle the folder/navigation pane as well as the Details pane and the Preview pane!

     

Log in to post a comment.