Run box behavior - focus and taskbar

markd89
2012-07-03
2012-10-29
  • markd89

    markd89 - 2012-07-03

    Hi,

    When selecting Start|Run, there are two minor annoying things I've seen:

    1.When the Run box appears, it ALSO appears on the Taskbar. This is not XP
    behavior.

    1. Related to #1, the taskbar has focus. I have to click into the Run box to type my command.

    Any suggestions?

    Thanks!
    Mark

     
  • xpclient

    xpclient - 2012-07-03
    1. This is because beginning with Vista, any "dialog box" (which doesn't have minimize, maximize buttons like a "window" has) also shows on the taskbar so that you can switch to it using the mouse (previously if a dialog went behind another window or dialog, you could only switch to it using Alt-Tab).

    2. I don't see this behavior. The Run is always focused when it opens and I am able to type commands directly and hit Enter. What happens if you open the Run box using Win key+R?

     
  • markd89

    markd89 - 2012-07-03

    Thanks for the quick response.

    On #2, I tried Windows Key+R and it does the same thing.
    a. Run opens on the task bar.
    b. The focus flashes alternating between the Run box and the Run on the
    taskbar.
    c. The run box takes no input until it's clicked on.

    I took a video to show you. I had a little trouble, but it seems to play OK in
    VLC on my machine...
    http://realityisreality.com/20120703_0739_48.theora.ogv

    Thanks again! (and VERY cool project BTW :-)

    Mark

     
  • xpclient

    xpclient - 2012-07-03

    Because Win+R also does the same thing, it's not something that Classic Shell
    is doing. Note that the Run dialog is not part of Classic Shell and it does
    nothing to control or change it. The Run dialog is a system dialog. From the
    video, I notice two things. 1. You are either operating with UAC entirely off
    or running Explorer elevated 2. You can using the Classic theme.

     
  • markd89

    markd89 - 2012-07-03

    Thanks for your help. I thought this was a Classic Shell issue and it's not.
    It happens with the regular shell and happens with other windows. doh!

    I found a solution. For anyone else who runs into new windows not being
    focused in Windows 7, I used this thread to fix it:

    http://answers.microsoft.com/en-
    us/windows/forum/windows_7-performance/windows-7-x64-pro-window-focus-
    issueswhen-i-open-a/a55aec2b-ee7e-40f2-bc8b-
    8f4728671ca4

    Copy-paste of solution:

    1. Open Start >> Run and type “regedit” (without quotes)

    2. Navigate to the following path:

    3. Right Click on the empty space and create a new DWORD value, or modify the existing value named ‘ForegroundLockTimeout’, set or modify the value to 0. (this value will cause the application to take the focus instantly.)

    4. That’s it Done, exit registry and restart windows for changes to come into effect.

    Thanks again!
    Mark

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks