Fatal Error: $_SESSION['sURLPath'] is empty.

Help
JimBerlin
2013-12-14
2015-06-08
  • JimBerlin

    JimBerlin - 2013-12-14

    This is my first try at logging into churchinfo after installing it.

    When I entered the correct user name and password, this message appeared:

    Fatal Error: $_SESSION['sURLPath'] is empty.

    Can anyone tell me what I need to do now?

    Thanks

     
  • JimBerlin

    JimBerlin - 2013-12-15

    Problem Solved!

     
    • stlouisubntu

      stlouisubntu - 2014-02-15

      Hey friend! I am really glad you solved the problem. Would you please share how you solved your problem. My pastor reported seeing the exact same error message.

      Thanks.

       
  • Michael Wilt

    Michael Wilt - 2014-02-20

    This is typically caused by a problem with the PHP installation. The session data is stored on the server and problems like this arise if the location that PHP thinks it should be using does not exist or is not writable. If this is your own server, you can get a start debugging by looking at phpinfo(). If you don't have an easy way to see this make a little php file in your htdocs directory and browse to it:
    <?php
    phpinfo();
    ?>

    Mike

    Michael Wilt
    ChurchInfo Team Leader

     
  • Michael Wilt

    Michael Wilt - 2014-02-20

    I just looked in the other forum and found an easier potential issue:
    https://sourceforge.net/p/churchinfo/discussion/401179/thread/769cae04/

    The root path set in Include/Config.php must point to the churchinfo installation with respect to the root path on your server, typically the htdocs directory. For example, the default value of "/churchinfo" works if you unpack the distribution into the "churchinfo" directory under htdocs. I have seen problems if the distribution is unpacked into the htdocs directory (without a churchinfo subdirectory), or if the distribution is unpacked into churchinfo/churchinfo. Either of these is surprisingly easy to do.

    Mike

    Michael Wilt
    ChurchInfo Team Leader

     
  • David Both

    David Both - 2015-05-29

    I am just getting started with this new installation and am having the same problem.

    So it looks from phpinfo like my version of Apache was configured without gd, pear, MySQL, and so on.

    How do I get these things activated??? How do I fix this? Help!!

    Configure Command './configure' '--build=x86_64-redhat-linux-gnu' '--host=x86_64-redhat-linux-gnu' '--target=x86_64-redhat-linux-gnu' '--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib64' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/var/lib' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--cache-file=../config.cache' '--with-libdir=lib64' '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d' '--disable-debug' '--with-pic' '--disable-rpath' '--without-pear' '--with-bz2' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--with-xpm-dir=/usr' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl' '--with-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-exif' '--enable-ftp' '--enable-magic-quotes' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--with-kerberos' '--enable-ucd-snmp-hack' '--enable-shmop' '--enable-calendar' '--without-sqlite' '--with-libxml-dir=/usr' '--enable-xml' '--with-system-tzdata' '--with-apxs2=/usr/sbin/apxs' '--without-mysql' '--without-gd' '--disable-dom' '--disable-dba' '--without-unixODBC' '--disable-pdo' '--disable-xmlreader' '--disable-xmlwriter' '--without-sqlite3' '--disable-phar' '--disable-fileinfo' '--disable-json' '--without-pspell' '--disable-wddx' '--without-curl' '--disable-posix' '--disable-sysvmsg' '--disable-sysvshm' '--disable-sysvsem'

     
  • Michael Wilt

    Michael Wilt - 2015-05-29

    There are certainly distributions available that have everything you need already. I recommend xampp for setting up PCs and they have a version for Linux as well.

    With Redhat you should be able to add whatever you need using commands like this:
    sudo yum install php-gd

    There is a more complete description of putting together a LAMP (Linux, Apache, MySQL, PHP) in this web page:

    https://www.digitalocean.com/community/tutorials/how-to-install-lamp-linux-apache-mysql-php-on-fedora

    Mike

    Michael Wilt
    ChurchInfo Team Leader

     
  • David Both

    David Both - 2015-05-29

    My server (CentOS 6.X with all current updates as of about 5 days ago) already has Apache, PHP and MySQL installed and working. I use WordPress (PHP and MySQL required) for multiple web sites on my server using Virtual hosts on a single IP address.

    I have checked the MySQL database and the tables were created correctly during the installation procedure. I simply used the default user, password and database name of churchinfo on this test installation. I restarted httpd and mysqld. httpd needs to be restarted but mysqld should not.

    The docroot for this virtual host is at /var/wwwboth/html so I put the churchinfo directory at /var/wwwboth/html/churchinfo and verified $sRootPath = '/churchinfo';

    php-gd, pear and gettext are already installed and at the latest version. MySQL and PHP are at versions 5.x.

    I have changed the ownership of all files in the churchinfo directory to apache.apache. I have not changed the file or directory permissions.

    I placed the churchinfo directory stanza inside the virtual host stanza for the web site in which I have churchinfo installed.

    I am using Firefox 38.0.1.

    I have tried setting the server name as localhost as well as its DNS name. The problem persists no matter what I have done so far.

    DO you have any other suggestions?

     
  • Michael Wilt

    Michael Wilt - 2015-06-02

    This error means that PHP is not able to store and retrieve session information:

    Fatal Error: $_SESSION['sURLPath'] is empty.

    Please run phpinfo- if you don't already have a way to do this just make a little script test.php in your churchinfo directory:
    <?php
    phpinfo();
    ?>

    Look in the session section. There is a variable session.save_path. PHP needs to be able to store stuff here. If it is working you should see current files in here that start with sess_ and continue with random characters.

    Mike

    Michael Wilt
    ChurchInfo Team Leader

     
  • David Both

    David Both - 2015-06-08

    SOLVED!!

    I have changed the permissions on the location /var/lib/php/session and I can now login without this error message. Thanks!

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks