[Problem/Help] Error creating device:...

  • jfa

    jfa - 2004-10-26

    Hi, all:

    I was trying to implement a UPnP device with
    CyberLink for Java, and it works okay
    (StateVariable can be queried/actions events were handled...)
    with the upnp-sample-controlpoint from CyberLinkJava

    Then, I found that the device could only be found
    by using CyberLink upnp-sample-controlpoint.
    When I tried to use Intel UPnP tool (Device Spy)
    or Siemens GenericControlPoint(from Siemens UPnP Stack/Java)
    Both tool could not find the device. :(

    I have tried testing different sample-devices done by
    using CyberLink Java. (Provided by CyberLink and others)
    They all work with both Intel & Siemens tool.

    The error message shown by Siemens UPnP tool is:
    Error creating device: No StateVariables defined in service
    urn:schemas-upnp-org:service: xxxxxxxxxxxx:1

    I really don"t know what could be wrong. Works with one CtrlPt
    but not another...
    Could anyone provide any suggestions/hints.

    Greatly appreciated!! :)

    • jfa

      jfa - 2004-10-26

      never mind.... :p


Log in to post a comment.