Hi Matthias, all

I have the same problem as Helga (Segmentation fault) on gentoo.

>>> from cgkit.all import *
ends with Segmentation fault

>>> import cgkit._core
>>> v=cgkit._core.vec3(1,2,3)
>>> print v
(1, 2, 3)

My configuration is:

gcc (GCC) 4.1.2 (Gentoo 4.1.2 p1.1)
Python 2.5.2
no extra packages

I've tried to build cgkit with gcc-4.1.2 and it still fails.

I wanted to try to compile against boost-1.31 but that version requires python-2.2 for compilation. I didn't find anything about the supported versions of python in the docs, is it possible that you are using python-2.2?

That import of cgkit.all fails at the module joystick but when I try to import only that module it doesn't fail. This Segmentation fault typically happens when freeing some memory twice or when accessing freed memory in general. So the error won't be bound to a partcular module, it will rather happen after certain number of wrong freeing, i.e. when it reaches a memory with wrong access. I noticed that you are using shared_ptr<> from boost, that's used exactly for preventing such errors. Perhaps it's still missing somewhere. Maybe that the implementation of boost has changed between the versions but maybe it depends on some other factors.

Do you have any ideas what to try or how to install boost-1.31 with python-2.5?

Or couldn't you try to upgrade to current boost?

I was very happy to find cgkit because it seems like exactly the tool I need, I don't want anything interactive. I would even try to use RenderMan directly but I have no experience and cgkit seems to be a good starting point for me because of the reasonable documentation.

I also tried to install cgkit on MacOSX, I had to install first the python-2.5 (the official mac installer from the python official site), the installation went fine but when I want to use it, I have problems with imports:

$ viewer.py sphere.py
Traceback (most recent call last):
  File "/usr/local/bin/viewer.py", line 56, in <module>
    import pygame

$ python
Python 2.5.4 (r254:67917, Dec 23 2008, 14:57:27)
[GCC 4.0.1 (Apple Computer, Inc. build 5363)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> from cgkit.all import *
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/cgkit/all/__init__.py", line 54, in <module>
    from cgkit.scene import Scene, getScene
  File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/cgkit/scene.py", line 41, in <module>
    from Interfaces import ISceneItem
  File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/cgkit/Interfaces/__init__.py", line 37, in <module>
    from isceneitem import ISceneItem, ISceneItemContainer
  File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/cgkit/Interfaces/isceneitem.py", line 37, in <module>
    from protocols import Interface
ImportError: No module named protocols

It looks like it my help to install some extra modules. But I didn't find anything in the documentation. Can you, please, suggest, what to do?