#15 supportLib doesn't compile

closed
nobody
None
5
2008-04-08
2008-04-07
Anonymous
No

I downloaded the lastest beta (8) and followed the indstructions.

got this error :

src/glmaterial.cpp:190: error: 'gluBuild2DMipmaps' was not declared in this scope

L

Discussion

  • Matthias Baas

    Matthias Baas - 2008-04-07

    Logged In: YES
    user_id=211477
    Originator: NO

    You need to provide more information about your system. What operating system are you on (what version is it)? What compiler (& version) are you using?
    Where did you get OpenGL from? What was the complete compiler output up to the above line?

    - Matthias -

     
  • Nobody/Anonymous

    Logged In: NO

    Sorry about the lak of detail. Here they are.

    My setup :
    ----------

    OS : Ubuntu 7.10
    compiler : gcc 4.1.3
    I use the binary driver from Nvidia (its an option on ubuntu : "use proprietary driver").

    Complete compiler output :
    --------------------------

    scons: Reading SConscript files ...
    My

    26 source files
    C++ compiler version: 4.1.3
    Checking for C++ header file boost/shared_ptr.hpp... (cached) yes
    scons: done reading SConscript files.
    scons: Building targets ...
    g++ -o obj/glmaterial.o -c -fPIC -Iinclude -I/opt/local/include src/glmaterial.cpp
    src/glmaterial.cpp:47:20: error: GL/glu.h: No such file or directory
    src/glmaterial.cpp: In member function 'void support3d::GLTexture::texData(int, int, int, int, char*)':
    src/glmaterial.cpp:190: error: 'gluBuild2DMipmaps' was not declared in this scope
    scons: *** [obj/glmaterial.o] Error 1
    scons: building terminated because of errors.

     
  • Matthias Baas

    Matthias Baas - 2008-04-08

    Logged In: YES
    user_id=211477
    Originator: NO

    > src/glmaterial.cpp:47:20: error: GL/glu.h: No such file or directory

    This line mentions the actual problem, the other one was just a follow-up error.
    The compiler cannot find the OpenGL header glu.h which means the headers are not installed or they are at a location where the compiler didn't search for them. So make sure the headers are available and, if necessary, update the config file to include the path to the headers (see the manual).
    It might be necessary that you install some additional "OpenGL dev" package or something like this (I don't know how Ubuntu is organized, just check your distribution).

    I have closed this bug report as this is actually not a bug in cgkit but just an incomplete build environment. Please use the mailing list if there are more problems during compilation.

    - Matthias -

     
  • Matthias Baas

    Matthias Baas - 2008-04-08
    • status: open --> closed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks