Just a request to have this modification in the next release.
I'm trying to remember why I genericized the produceDataset method in the first place. Changing the signature in an interface for little gain doesn't seem to make a lot of sense, as it forces folks to update their code. I really can't remember; it would seem to have been a not-so-good decision.
Changing the ChartPostProcessor interface was rather different, that still makes sense.
Fair enough. I'll add @SuppressWarnings.
If folks (you or someone else) thinks this is of substantial value, I'll certainly consider it, but right now I'm still stumped why I changed the other method signature. Genericizing is good, but breaking an interface for what now looks like little value - not so much.
I don't think it's that big of a deal. Only brought it up after noticing the change to the produceDataset method, then I wondered why not this other one.
Sign up for the SourceForge newsletter:
You seem to have CSS turned off.
Please don't fill out this field.