Another problem, Semantic can parse Eigen library after adding the mode cookie, but the auto-compeletion still doesn't work :(
I utilize the company-mode, it works perfectly for C++ STL and other headers except Eigen. Maybe it's due to the Eigen library is too complicated.

Zhu Zhongshu

------------------ 原始邮件 ------------------
发件人: "朱仲书";<zhuzhongshu@foxmail.com>;
发送时间: 2013年12月21日(星期六) 晚上9:47
收件人: "Eric M. Ludlam"<eric@siege-engine.com>;
主题: 回复: 回复: [CEDET-devel] Problems About Semantic

OK, I will correct it in my topic about this problem in Eigen forum.
I don't know the meaning of mode cookie before, Thanks for your correction and explanation~

Zhu Zhongshu

------------------ 原始邮件 ------------------
发件人: "Eric M. Ludlam";<eric@siege-engine.com>;
发送时间: 2013年12月21日(星期六) 晚上9:34
收件人: "朱仲书"<zhuzhongshu@foxmail.com>;
主题: Re: 回复: [CEDET-devel] Problems About Semantic

Hi Zhu,

I'm glad it worked.

I see a typo in my first message is propagating.  I should have typed:

mode cookie

A mode cookie is a small identifier that can be picked up by emacs to
identify the mode of the file when extensions don't work.


On 12/21/2013 06:47 AM, 朱仲书 wrote:
> Hello:
> I add the mode cooking in one Eigen header file and Semantic can parse
> it now~I will try the second method later because I need to report this
> minor problem to the Eigen group.
> Many Thanks~
> Zhu Zhongshu
> ------------------ 原始邮件 ------------------
> *发件人:* "Eric M. Ludlam";<eric@siege-engine.com>;
> *发送时间:* 2013年12月21日(星期六) 中午11:48
> *收件人:* "朱仲书"<zhuzhongshu@foxmail.com>;
> *抄送:* "cedet-devel"<cedet-devel@lists.sourceforge.net>;
> *主题:* Re: [CEDET-devel] Problems About Semantic
> On 12/20/2013 08:19 AM, 朱仲书 wrote:
>  > Hello:
>  > My name is Zhu Zhongshu, a student in China.
>  > I have a small problem about the parser. When I am using the linear
>  > algebra library called "Eigen" in my code, I find the company-mode can't
>  > work for this library. Because the semantic will not parse the header
>  > files without any suffix, for example "Dense" instead of "Dense.h" .When
>  > I add the suffix .h, it works well.
>  > After this, I write a simple header file without suffix .h, the same
>  > problem happens again. I really don't know how to deal with it, so I use
>  > CB now...
>  > Please give me some suggestions ,many thanks!!
> Hi,
> You probably need to add a mode cooking into your header file, such as:
> // Components for manipulating sequences of characters -*- C++ -*-
> which came from the c++ "string" header on my Linux box.
> If you can't edit them, add something to your auto-mode-alist, such as:
> (add-to-list 'auto-mode-alist '("^/path/to/some/headers/" . c++-mode) t)
> to force that stuff to be in C++ mode.
> Good Luck
> Eric
> .