Thanks for the help Eric.

It's funny, just after posting to the list I tried copying semantic-el.el to semantic-picolisp.el and changing it as required to work for PicoLisp and that did the trick, more here:

Probably not the cleanest solution but it works.

On Tue, Jun 14, 2011 at 6:33 PM, Eric M. Ludlam <> wrote:
Hi Henrik,

 I don't know much about picolisp, but if it is similar to Emacs Lisp and common Lisp, then you can probably do the same thing in semantic-el.el, and at the very end of that file, add a new hook similar to the one that is there for common lisp.

 If that works, then you are in good shape.

 As for the error, I think semantic-scm may have not been updated for the new tag formatting functions.  Here is a revised version:

(define-mode-local-override semantic-format-tag-prototype scheme-mode (tag &optional parent color)
 "Return a prototype for the Emacs Lisp nonterminal TAG."
 (let* ((tok (semantic-tag-class tag))
        (args (semantic-tag-components tag))
   (if (eq tok 'function)
       (concat (semantic-tag-name tag) " ("
               (mapconcat (lambda (a) a) args " ")
     (semantic-format-tag-prototype-default tag parent color))))

I'd try just using the regular lisp parser first, which should be ok so long as the lexical syntax is the same as Emacs Lisp.


On 06/04/2011 10:40 AM, Henrik Sarvell wrote:
Hi All.

I am "successfully" using CEDET with Clojure, successfully in the way
that if I open a Clojure file I get the function list for it in a ECB
function/method buffer so I can easily browse to any given function as
well as see which functions are defined.

I have no idea how this works since I can't find any Clojure
lexers/parsers in the semantic/bovine/wisent folders.

Anyway, this code browsing feature is what I'm looking for but for
PicoLisp ( ) too.

There already is a major mode for picolisp which seems to be working
fine with regards to the instructions here: in the sense that it seems
to be doing all that is required there.

Then I created and semantic-picolisp.el (attached), I
simply based them on and semantic-scm.el  as I don't know
anything about these things.

These files generated the attached semantic-picolisp-by.el file.

Firing up emacs and editing a file will however not display any
defined functions in the method buffer.

When i run semantic-test-all-format-tag-functions I get what you see
in the attached screenshot.

I run it when I have the attached simple.l open.

Any ideas? It's a simple lisp we're talking about here so maybe
there's some shortcut that will make the function buffer work properly
without launching a completely new parser (thinking about why it works
with clojure despite there not being any dedicated parser...)

Thanks in advance!

/Henrik Sarvell



Simplify data backup and recovery for your virtual environment with vRanger.
Installation's a snap, and flexible recovery options mean your data is safe,
secure and there when you need it. Discover what all the cheering's about.
Get your free trial download today.

Cedet-devel mailing list