Hi David,

Thanks a lot for your help. I just tried manually deleted the .semanticdb and .srecode directories and it seems to be working now, though it's still too early to tell, as this had happened before that after the semantic database being forced to rebuild, it worked and I was relaxed but that had never worked long enough, after awhile I was disappointed again. However, this time it might be different as you did find something wrong in the code and you mentioned about deleting the database, put it another way, I'm much more confident this time that it will work.

What does 'bzr revert' really do? Will it remove all '.elc' files?

I will keep you updated if it works for me consistently.

Have a nice weekend,


On Fri, Mar 25, 2011 at 12:09 PM, David Engster <deng@randomsample.de> wrote:
David Engster writes:
> York Zhao writes:
>> Just want to let you know that I've already sent an email to the
>> mailing-list with a 40K attachment which is a text file of the entire debug
>> information. However, I got an automatic reply immediately after my email
>> gets out saying that my email had been held for approval as it was too
>> large. I don't know whether you have any control over this and how long the
>> delay would be before you can get my email. Should I cut the file and resend
>> again?
> Hi York,
> Please send it directly to my private mail address.

I received the backtrace, thanks. Unfortunately, although it's long, it
doesn't tell much. ;-)

Another two questions before I dig deeper:

After updating from bzr and recompiling CEDET, did you delete all files
from your semanticdb cache? (BTW, you can get a clean checkout again by
doing 'bzr revert').

You say this error always happens - does that refer to your project
only, or do you see this even with the simplest test cases, for example

----- main.cpp -----
class myClass {
 int foo;
 int bar;

int main() {
 myClass a;
 a.  // complete here

If the above works, I'm guessing it is a certain header file from your
project which Semantic cannot parse correctly. It would help greatly if
you could find out which header file exactly is causing the error.


Enable your software for Intel(R) Active Management Technology to meet the
growing manageability and security demands of your customers. Businesses
are taking advantage of Intel(R) vPro (TM) technology - will your software
be a part of the solution? Download the Intel(R) Manageability Checker
today! http://p.sf.net/sfu/intel-dev2devmar
Cedet-devel mailing list