You run a Windows-release of Emacs-22, right?
I had the same problem nr. 2 (no icons) and it costs me about 4 hours to solve it:
Unfortunately the Windows-package does not contain the needed image-libraries necessary to display some image types - even the xpm-imagetype can not displayed :-( You have to install manually the following libraries:
jpeg62.dll  libpng13.dll  libtiff3.dll  libungif4.dll  xpm4.dll  zlib1.dll
xpm4.dll is needed to display the xpm-icons of ECB - just copy this library in the bin folder of your emacs-22 installation path and Bob will be your uncle....
ad problem 1: This is a cedet issue - AFAIK eric has cutted all the nifty cedet-features in some presets (a minimal set, a full set and something in between i think) - i assume in the cedet-pre4-package the semantic-stickyfunc-mode (its responsible for this nifty headerline ;-) is disabled by default; just add to your .emacs (after the setup-code for cedet) the following line:
(global-semantic-stickyfunc-mode 1)
and Bob will be your uncle again ;-)
@Eric: please correct me if i wrote nonsens
Hope this helps,

From: Oviedo Javier-PKJ843 []
Sent: Wednesday, June 13, 2007 5:06 PM
To: Berndl, Klaus
Subject: RE: ECB issues with latest CEDETpre4 and Emacs22.1

Message bounced due to size...

From: Oviedo Javier-PKJ843
Sent: Wednesday, June 13, 2007 11:04 AM
To:; ''
Subject: ECB issues with latest CEDETpre4 and Emacs22.1

Hi Klaus,
Just upgraded to the latest Emacs 22.1. Also upgraded to the latest cedet for compatibility reasons....using the same ecb snapshot you said was the most recent.
I'm seeing some issues:
1. Not sure exactly what the proper name for this is, but the header line at the top of the edit window no longer displays. This is the line that shows the current function we are in, etc.
2. The icons/images in the methods buffer window, history window, and speedbar window no longer display.
Before reporting this tried the following things:
1. cleaned ECB and recompiled with the latest cedet.
2. Tried a ECB without any of my customizations.
3. Then tried ECB with a plain vanilla emacs.
I can send some screenshot over in a word document if you'd like.
See the bug report below.
X-Reporter-Void-Vars-Found: ecb-max-lisp-eval-depth-old ecb-max-specpdl-size-old ecb-use-semantic-grouping
--text follows this line--
Please enter the details of your bug report here
Emacs  : GNU Emacs 22.1.1 (i386-mingw-nt5.1.2600)
 of 2007-06-02 on RELEASE
Package: ECB: 2.33beta1, semantic: 2.0pre4, eieio: 1.0, speedbar: 1.0.1, JDEE: No JDEE