1. semantic-elp-analyze works fine for me now, but i can not use C-c C-s to exit anymore. I checked it and found some files such as init.el can not be saved without error while other files can be saved successfully. Since some files must be saved when Emacs exits, i think semantic-elp-analyze may ruin something about that.

I used several addons such as ido and desktopaid,  So I toggled debug on error and found these:

Debugger entered--Lisp error: (wrong-number-of-arguments #<subr sort> 1)
  #<subr sort>(chinese-hz)
  #[(x y) "    !\n!V" [func x y] 3](chinese-hz chinese-gbk)
  #<subr sort>((iso-2022-jp-2) #[(x y) "    !\n!V" [func x y] 3])
  apply(#<subr sort> ((iso-2022-jp-2) #[(x y) "    !\n!V" [func x y] 3]))
  elp-wrapper(sort nil ((iso-2022-jp-2) #[(x y) "    !\n!V" [func x y] 3]))
  sort((iso-2022-jp-2) #[(x y) "    !\n!V" [func x y] 3])
  find-coding-systems-region(1 34259)
  select-safe-coding-system(1 34259 utf-8 nil "/home/bread/.ido.last")
  write-region(nil nil "/home/bread/.ido.last" nil t "~/.ido.last")
  write-file("~/.ido.last" nil)
  call-interactively(save-buffers-kill-terminal nil nil)

It seems that elp-wrapper has something with these errors.

2. After semantic-elp-analyze completes, there's a prompt which asks me to save the file, like this:

Save Profile to: ~/semantic.elp

But after i click enter, there's an error showed up which told me

Debugger entered--Lisp error: (file-error "Opening output file" "permission denied" "/semantic.elp")...

It seems that "~/semantic.elp" was changed to "/semantic.elp". It worked fine after i manually changed the path to /home/bread/semanticlog.

On Mon, Dec 8, 2008 at 8:13 PM, Eric M. Ludlam <eric@siege-engine.com> wrote:
>>> bread <breaddawson@gmail.com> seems to think that:
>On Mon, Dec 8, 2008 at 9:30 AM, Eric M. Ludlam <eric@siege-engine.com>wrote:
>> [...]
>> If you have a simple motion that cause slowness, go to recreate it,
>> but instead of using normal completion, use the profiler:
>> M-x semantic-elp-analyze RET
>> It will prompt you to save the profiler results in a file which you
>> could email me.  Alternately, you can look through the results
>> yourself, and perhaps you will learn something yourself.
>I triggered 'M-x semantic-elp-analyze' in several different files, but got
>the same error msg:
>mapcar: Symbol's function definition is void:
>But if i use the normal completions, it's fine.
 [ ... ]

semantic-elp needs to list all the functions it will profile.  That
one apparently got deleted sometime.  I checked in a fix.

If you find issues like that in the future, you can just open
semantic-elp.el, and remove the offending missing function from the
lists of functions being profiled.


Zhiqiu Kong (孔直秋)