I updated cedet from cvs and found this bug was fixed.

Thank you very much for your help!!

On Thu, Oct 9, 2008 at 8:09 AM, Eric M. Ludlam <eric@siege-engine.com> wrote:
I was able to find the problem.  There is an updated version of
semanticdb-find.el in CVS that should solve this.


>>> bread <breaddawson@gmail.com> seems to think that:
>Thank you for your explanatation. Now i know what the probem is. But
>actually i'm using CEDET from CVS, and Emacs from CVS, too.
>I updated CEDET just now and tried again, following the 2 steps will still
>get senator.el opened automatically.
>Btw, this is not a big issue for me until i tried a new extension which is
>called company(http://nschum.de/src/emacs/company-mode/). It's a completion
>front-end and will load semantic for completions. Before i used this
>extension, there happeded to be header files automatically opened, but after
>i used it, everytime i typed "#include <string>", for example,  there're
>many headers opened.
>At first i think maybe this is a bug of company, but when I looked into the
>source codes of company and found there're few commands used to interactive
>with semantic:
>I can not figure out what the problem is , So i think maybe i need to ask
>for help here . And it really seems a bug of semantic.
>On Sun, Oct 5, 2008 at 9:58 PM, Eric M. Ludlam <eric@siege-engine.com>wrote:
>> Hi,
>>  If you are using the last pre-release (1.0pre4) then what you are
>> observing is a bug.  This bug should be fixed in the CVS version.
>>  You are correct, that CEDET tries to open various header files to
>> provide smart summaries and completion.  It will still do that in the
>> CVS version, but should also correctly clean up those buffers
>> afterward.
>> Eric
>> >>> bread <breaddawson@gmail.com> seems to think that:
>> >Hi,
>> >
>> >I'm using the latest Emacs and cedet and i found there're always some
>> header
>> >files opened automatically when i wrote C++. It was wired. What's more, i
>> >found some el.gz files opened automatically, too. And i found a method to
>> >reproduce this "bug"(i'm not sure if it's a bug):
>> >
>> >Open an el file, whatever, senator-ia.el for example.  there's a *(require
>> >'senator)*. So, do the followings:
>> >
>> >1. C-s, type senator.
>> >Yes, we're searching senator, and the cursor will stop at the one in
>> >(require 'senator)
>> >
>> >2. Hit enter and u'll find another senaotr.el.gz was opened.
>> >
>> >I don't know why this happed and if this is related to the header files
>> auto
>> >opened issue which was mentioned above. But it seems not a feature of
>> cedet?
>> >And after i comment all the things related to cedet and restart emacs,
>> >everything was ok.
>> >
>> >This is not a special case since a friend of mine can also get el.gz file
>> >opened by following the 2 steps.
>> >
>> >so,  i think maybe it was caused by the anlyzing process of semantic?
>> maybe
>> >semantic need to open the header files to get the tags of cpp files ,and
>> >with the same reason, semantic need to open el.gz files?
>> >
>> >Thanks.
>> >

Zhiqiu Kong (孔直秋)