Hi, Eric.

I tried both "C-u M-x bovinate RET" and "Force Tag Refresh", but test2.h is still can not be found, and also I can not get the completion. Beside, I also tried to delete all the semantic cache file, but the problem is still at here.

在2009-01-25,"Eric M. Ludlam" <eric@siege-engine.com> 写道:
>  If you configured the ede-locate part after your file with test2.h
>was first parsed by Semantic, it could be that a bad value was cached
>into the tag.  Try using
>C-u M-x bovinate RET
>or use the Senator menu, and first menu item "Force Tag Refresh" to
>clear that.
>>>> yupeng82921 <yupeng82921@163.com> seems to think that:
>>Hi, Eric.
>>According to your answer, I know how to find th"summarize includes", and th=
>>is is the result of summarize includes:
>>Include Summary for File: /home/yupeng/work/emacs/test2/test2.c
>>This file contains 4 tags, 3 of which are includes.
>>   Unknown Includes:  2
>>   Unparsed Includes: 0
>>   Parsed Includes:   1
>>Include Path Summary:
>>  This file's project include is handled by the EDE object:
>>    #<ede-cpp-root-target /home/yupeng/work/emacs/test2/>
>>  This file's system include path is:
>>    /usr/include
>>All unknown includes:
>>  test2.h
>>  test1.h
>>There are currently no includes found recursively.
>  [ ... ]
>          Eric Ludlam:                       eric@siege-engine.com
>   Siege: www.siege-engine.com          Emacs: http://cedet.sourceforge.net