#17 Loading a large design causes cedarlogic to crash

v1.3 with Z80
open
Crashes (8)
5
2008-05-27
2007-10-10
No

I've just encountered a weird bug. I created a rather large design which worked just fine in cedarlogic. After saving the design and loading it again cedarlogic crashed after about 10 seconds. I've encountered the bug in at least one real design (which I don't want to attach here because it contains solutions to some labwork which we have) and one design I just created by copy/pasting some random circuit a number of times. I have attached the later to this bug report.

To reproduce: Just doubleclick cedarcrash.cdl and wait for cedar to crash. (For me it crashes after about 5 seconds.)

Discussion

  • Andreas Ehliar

    Andreas Ehliar - 2007-10-10

    A relatively large design, created by copy/paste.

     
  • Joshua Edward

    Joshua Edward - 2007-10-18

    Logged In: YES
    user_id=1612530
    Originator: NO

    What version of CEDAR logic do you have installed?

     
  • Andreas Ehliar

    Andreas Ehliar - 2007-10-30

    Logged In: YES
    user_id=3335
    Originator: YES

    Hi, I'm using the latest version where the del bug has been fixed. I also tried to compile cedarlogic from source code and got the same problem but unfortunately I couldn't find any more information from gdb in that way.

     
  • Joshua Edward

    Joshua Edward - 2007-11-15

    Logged In: YES
    user_id=1612530
    Originator: NO

    The large file does not cause Cedar LOGIC to crash on my machine. How much do you have? I have 896M of ram.

     
  • Andreas Ehliar

    Andreas Ehliar - 2007-11-21

    Logged In: YES
    user_id=3335
    Originator: YES

    There is 2 gigabyte of memory in my Windows XP based computer. Do you have any hint about how I could debug this issue?

     
  • Matt Lewellyn

    Matt Lewellyn - 2008-05-27

    Logged In: YES
    user_id=1522225
    Originator: NO

    I'm going to try to get these crash bugs resolved. Wasn't able to make it crash with this circuit or much larger circuits.

    Since I've made some changes to the code base, please compile the source in the svn trunk folder and try this again. Note that wxWidgets 2.8.7 is required now (upgraded from 2.6.2). If it still crashes, let me know and I'll enable some logging in the next revision. Also, are you having this issue on the one computer only?

     
  • Matt Lewellyn

    Matt Lewellyn - 2008-05-27
    • assigned_to: nobody --> mattosaur
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks