Help save net neutrality! Learn more.
Close

#11 Full Adder terminal swapped

v1.1
closed-fixed
nobody
1
2007-08-18
2007-08-09
Anonymous
No

The Carry-out and the Sum terminals of the Full Adder is swapped.

this is what is expected
A B Cout S
0 0 0 0
0 1 0 1
1 0 0 1
1 1 1 0

but this is what is actually happening
A B Cout S
0 0 0 0
0 1 1 0
1 0 1 0
1 1 0 1

Discussion

  • Benjamin Sprague

    Logged In: YES
    user_id=1312775
    Originator: NO

    Yup. We found this bug earlier, though, and have released a patch for it in the "Patches" tracker. However, I believe this is also fixed in our newest release (1.3 with Z80), so you may want to just try the newer version rather than trying the patch.

     
  • Benjamin Sprague

    • priority: 5 --> 1
     
  • Joshua Edward

    Joshua Edward - 2007-08-11
    • status: open --> closed
     
  • Benjamin Sprague

    Logged In: YES
    user_id=1312775
    Originator: NO

    I'm going to leave this bug listed as "open" even though it is fixed, so that people with a pre 1.3 release will know that the problem is fixed in the new version.

     
  • Benjamin Sprague

    • milestone: --> v1.1
    • status: closed --> open-fixed
     
  • Benjamin Sprague

    • status: open-fixed --> closed-fixed
     

Log in to post a comment.