Burning SVCDs from bin/cue

Help
Pab
2003-01-11
2003-01-13
  • Pab

    Pab - 2003-01-11

    When i try to burn an svcd from bin/cue all i get is coasters. The cd burns fine, no errors or problems, but i can't play back the mpeg on linux, windows or my dvd player. the cd shows up as being 600k total but the file size is fine in the mpeg directory. i've done it with images from multiple svcd's that are complete and pass crc checks and have had no luck. And if i extract the mpg from the bin/cue it plays just fine. I have even tried recreating the bin/cue with gnu vcdimager with the same results.

    running it like this:
    cdrdao write --device 0,3,0 --driver generic-mmc --speed 32 filename.cue

    with a lite-on 48x burner, kernel 2.4.19 and the cdrdao 1.1.7 compiled on my machine.

     
    • Pab

      Pab - 2003-01-11

      here's some more info:
      Tried to burn it at 1x with the same results..
      I get an I/O error when i try to copy or access the file from the disc.
      # ls -l
      total 715400 -r-xr-xr-x    1 root     root     732569600 Jul 14  1978 avseq01.mpg*
      but it shows up as 841,312,256 bytes in win2k

       
      • Julio Sánchez Fernández

        You cannot access some parts of (S)VCD disks from Linux, the iso9660 support expects that 1) all sectors in the disk are the same size (not true here) and 2) that all sectors referenced in directories are contained within the limits of the enclosing filesystem/track (not true here either).

        To read such disk on Linux, you need a program that plays the disk without trying to access the files through an iso9660 filesystem.  Xine knows how to, mplayer most likely knows at well, just select the proper input plugin.  You can play them on Windows directly, however, with any MPEG2 player.  Of course, you may also use a a proper SVCD player  or  a plugin for some other player.

        To extract those files from the disk itself, use vcdxrip from the vcdimager package.  Check if vcdxrip can do it.  If it can, the disk is probably semi-OK.

        The size difference comes from Linux expecting the file to have the same sector size (2048 bytes) as the iso9660, while Windows is computing the size using the raw sector size (2352 bytes).  Do the math.

        Why you cannot read them on your standalone player is harder to say, but as a hint, DVD players must have dual laser to read properly CD-R disks.  Try with CD-RW or a different CD-R make (with different reflectivity, Princo-branded CD-R's are often mentioned as helping people with this problem).  Another possibility is that your player only works with VCD, not SVCD.

         
    • Pab

      Pab - 2003-01-13

      my god!!! mplayer is playing it just fine if i load it as a vcd.. thank you so much, only problem is that i now have 15 copies of the 1st cd.. thank god the cost of media has come down.. thanx so much i was going crazy try to burn this stuff..

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks