OSX usage

  • aeriograph

    aeriograph - 2007-10-04

    Please, how do I use cdrdao under OSX?  (iMac G5)

    I have no idea how to get it to see the CD drive...   Had to transfer files to a Linux system, where it worked fine!


    • Jakub Hadraba

      Jakub Hadraba - 2007-10-06

      Try --device IOCDServices or --device IODVDServices.


      • aeriograph

        aeriograph - 2007-10-07

        Woohoo!!!!!  IODVD works!

        Now, please tell me how on Earth you knew that.  It isn't in /dev for instance...

        I do get an error message on burning (4th-last line below):

        IODVDServices: MATSHITA DVD-R   UJ-846  Rev: FA0G
        Using driver: Generic SCSI-3/MMC - Version 2.0 (options 0x0000)

        Starting write at speed 4...
        Pausing 10 seconds - hit CTRL-C to abort.
        Process can be aborted with QUIT signal (usually CTRL-\).
        WARNING: No super user permission to setup real time scheduling.
        Turning BURN-Proof on
        Enabling JustLink.
        ERROR: Cannot set Ricoh mode page 30.
        Executing power calibration...
        Power calibration successful.
        Writing track 01 (mode AUDIO/AUDIO )...

        Any idea what that is?  The disc seems to have burned alright though.

        Thanks so much!

    • Jakub Hadraba

      Jakub Hadraba - 2007-10-09

      Concerning this: ERROR: Cannot set Ricoh mode page 30.

      I don't know what it means, didn't find anything in the manual and/or the Internet. Increasing verbosity doesn't bring much as well. However, it doesn't seem to bring on any limits for my general usage.

      Concerning this: WARNING: No super user permission to setup real time scheduling.

      I wanted to burn a CD at 8x speed, got this message and burning proceeded with 24x speed. Adding "sudo" before "cdrdao + params" (and providing the super user password) allowed cdrdao to burn at the speed I specified.

      This is the way it worked and works at mine. I am very unhappy that the manual pages don't talk about frequent error messages since this would really save time! The other thing I am confused about is the pregap issue and certain problems with copying CDs which I talked about here recently and which were discussed here since long ago. However, as the traffic of this forum indicates, we can't expect things to get changed shortly.

      I hope the provided explanitions helped you a bit,


      • aeriograph

        aeriograph - 2007-10-18

        I also had some concern re "No super permission"!  I did notice at the end of one burn that one of the buffer minimums was perilously low - 3% or something.  Not sure how significant that is.  All other times they've been above 95%.

        I also had a speed issue, where it decided to burn a 24x CD-R at 8x, and specifying 16x did nothing.  Of course, it could be a mislabelled CD-R.  I'll try sudo next time.  Did that help with the "No super permission"?

        If you want to contact me directly, I might be able to help you with gaps and such, in a general sense that is...

        Thx again for the help.  I've now burned several CDs on my Mac - no need to transfer to my Linux system!

        md at cantares dot on dot ca


Log in to post a comment.