Three patches, aimed at master.
patch 2 seems to replace usage of Molecule with Molecule, rather than IMolecule
The second patch doesn't actually replace the use of Molecule; the reordering of the import is a side-effect of Eclipse trying to be smart. Should I change that? It is in the tests, which are free to pick any implementation.
The explain this use of IAtom instead of Atom, is that after the refactoring I am working on, PseudoAtom extends NNPseudoAtom, and not Atom.
Aah, OK. That makes sense. But given that we tell people to look at the unit tests to see how to use classes, shouldn't the unit test be an exemplar of 'good' CDK style?
I fully agree. That said, many unit tests need coding cleaning, much like the library itself. I had not really given it though yet, but it should not be too difficult to write PMD tests to test of local fields are Molecule or IMolecule. Or, Atom versus IAtom, etc.
Anyway, the code change does not change any line with Molecule/IMolecule, except for the bloody reordering by Eclipse...
If it is OK with you, I focus on getting the refactoring finished... but will give the PMD test a quick look...
OK, makes sense. Applied and pushed
Sign up for the SourceForge newsletter:
You seem to have CSS turned off.
Please don't fill out this field.