Hi,

It make sense to be in io.random (or similar), at least it uses different constructor (needs File instead of InputStream or Writer) and doesn't derive from iterator types. 

Nina

Egon Willighagen wrote:
On Wed, May 21, 2008 at 3:18 PM, Rajarshi Guha <rguha@indiana.edu> wrote:
  
That sounds like an excellent idea, and nicely complement the two
other types of reader we have.

So, a package io.random?
      
Why not just io?
    

Because to have iterators in io.iterator, read-all-into-memory in io,
and random in io.random...

Keeps different types together...

Egon