(no subject)

Page 1.0 of 1.08
  • John May

    John May - 2012-10-31

    Oh and we can also do this...

        public void add(IAtomContainer atomContainer);
        public void add(IAtom atom);
        public void add(IBond bond);

    currently code reads as follows:

    container.addAtom(atom) - container add atom atom

    this could easily be reduced to

    container.add(atom) - container add atom

    The existing methods could stay but the util methods would make implementing code look a lot cleaner.

  • John May

    John May - 2012-10-31
    • milestone: -->

Log in to post a comment.