#19 compilation older: copiles with older gcc but not older glib

None
wont-fix
nobody
complation (1)
unassigned
high
2014-01-18
2014-01-18
No

the requirements in project said that need glib

in changes note that removed use of anonymous unions, now compiles in gcc 4.2, 4.3 and 4.4 for debian squeeze and so other little distributions..
but still need GLib 2.28 as minimun for compile that reflects the configure script and the README file..

that non-sense due gcc 4.6 are minimun for use glib 2.30+ and newer gobject system..

but the main problem its that its not able to copile in those litle distributions.. such slitaz, oldstable debian live cd based (many based on squeeze) that still use GLIb 2.25 and lower releases...

Discussion

  • Rok Mandeljc

    Rok Mandeljc - 2014-01-18
    • status: open --> wont-fix
    • Milestone: -->
     
  • Rok Mandeljc

    Rok Mandeljc - 2014-01-18

    Hey,

    the use of anonymous unions was removed because it was breaking compilation with gcc 4.5 under gentoo. This might have made code compile under even older gcc versions you mention, but it does not imply support for older distributions, such as debian squeeze. If debian squeeze is explicitly mentioned anywhere, the text should be corrected, as it has not been supported for few CDEmu releases now.

    The main issue is that CDEmu daemon uses GDBusConnection and related objects, which were introduced in GLib 2.26. So while it is possible to build latest version of libMirage (by backporting some of CMake functionality) on squeeze, it is not possible to build the latest version of the daemon...

    I suppose to use CDEmu on distributions with GLib 2.25 or lower, one would have to use older CDEmu release; in this case 1.4.0, which was the last version before we moved from old dbus-glib bindings to GIO/GDBus.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks