There're some reasons that preventing us from using the latest version. Besides I looked at the relevant code segments, and it seems that it's the same on 4.5 and 5, so it won't solve the problem...

Arik Fraimovich ツ
visit my blog:
follow me on twitter:

On Thu, Jul 17, 2008 at 10:30 PM, Jon Phillips <> wrote:
Arik, you can try latest cchost version released 4.5 or be brave and try svn trunk...patches welcome!

Jon Phillips
Business Development +
Community Manager
Creative Commons

global: +1.415.830.3884
china: +86.1.360.282.8624
skype & im: kidproto

On Thu, Jul 17, 2008 at 8:08 AM, Victor Stone <> wrote:
2008/7/17 Arik Fraimovich <>:
> This didn't work either. I tried using fopen->fread->outputing waht was
> read- same result. I tried fread and then writing what I get to the disk,
> and I see that the file read is OK. So the problem is somehow with the
> output.
> Also I created a script that all it does is the above lines - and it worked
> OK on the same server.
> Anyone has any ideas?

There was once a problem with someone connecting with a dual IP
connection I've since removed that code post 4.01

The offending code:

 ($ip != $_SERVER['REMOTE_ADDR'])

There could also be an issue where headers or HTML were already send
when trying to send the Content header - if you have any custom code
make absolutely sure that all the '<?' are lined up to be the first
byte in the php file(s).

Other than that I'm not sure what could be going on...


This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
Cctools-cchost mailing list