I though that the problem might be with the headers, and I checked this. But the headers are send OK, but the content comes corrupted. It seems like it goes through some filter or something. Same code version works for me on another server, so I suspect that this is something with server configuration (or PHP version). Will investigate further tomorrow, if anyone has an idea I will appreciate.

Arik Fraimovich ツ
visit my blog: http://www.arikfr.com/
follow me on twitter: http://twitter.com/arikfr

On Thu, Jul 17, 2008 at 6:08 PM, Victor Stone <fourstones.net@gmail.com> wrote:
2008/7/17 Arik Fraimovich <arik@arikfr.com>:
> This didn't work either. I tried using fopen->fread->outputing waht was
> read- same result. I tried fread and then writing what I get to the disk,
> and I see that the file read is OK. So the problem is somehow with the
> output.
>
> Also I created a script that all it does is the above lines - and it worked
> OK on the same server.
>
> Anyone has any ideas?

There was once a problem with someone connecting with a dual IP
connection I've since removed that code post 4.01

The offending code:

 ($ip != $_SERVER['REMOTE_ADDR'])

There could also be an issue where headers or HTML were already send
when trying to send the Content header - if you have any custom code
make absolutely sure that all the '<?' are lined up to be the first
byte in the php file(s).

Other than that I'm not sure what could be going on...

VS