I just upgraded from 5.31.3 to 5.32.2 and the behaviour of c-fill-paragraph does not work correctly anymore, when I run the command it fills the comment but also moves the next line up and places it at the end of the comment. This behaviour is apparent with both // and /* style comments i.e. if I run c-fill-paragraph in the following comment:

 

// this is a comment

A = 100;

 

The buffer becomes:

 

// this is a comment                     A = 100;

 

I tried the previous version (5.32.1) but it had the same behaviour. Since I cannot imagine that the two versions were released with this feature as a “bug”, I must presume that there is something wrong in my .emacs file – any idea what it is that might be triggering this behaviour?

 

In the meantime I have returned to using 5.31.3.

 

Thanks

Peter

 

 

Peter Milliken

Software Engineer

 

"I Program - therefore I am"

 

ResMed Ltd

1 Elizabeth Macarthur Drive

Bella Vista NSW 2153 Australia

 

Tel: +61 2 8884 1000

Dir: +61 2 8884 2316

Fax:+61 2 8884 2006

email: peterm@resmed.com.au

 


Warning: Copyright ResMed. Where the contents of this email and/or attachment includes materials prepared by ResMed, the use of those
materials is subject exclusively to the conditions of engagement between ResMed and the intended recipient.

This communication is confidential and may contain legally privileged information.
By the use of email over the Internet or other communication systems, ResMed is not waiving either confidentiality of, or legal
privilege in the content of the email and of any attachments.
If the recipient of this message is not the intended addressee, please call ResMed immediately on +61 2 8884 1000 Sydney, Australia.