can't find java

  • Nobody/Anonymous

    When I run the installer I get an error
    "The installer could not find a valid Java(tm)
    Runtime Environment in this machine."
    I know I have an up-to-date version of java, I installed it hours ago. And I know it's in the right place, I ran another java program just fine. Java is in /usr/java on my computer.

    • Bradley Swartout

      on my installation I installed java which extracted the java directory into the directory I downloaded the bin file to (from sun).  It extracted there and I then moved the directory to the /opt directory, which is suppossed to be the standard location for java.  But I have had success with the binary installer for cbviewer by moving the directory to the /usr/local directory as well.  Both of those locations work.  Unfortunately I don't have any way at the moment to see where the binary installer looks for java.

      You could always download the tarball and you would then just edit the shell script to launch cbviewer to point to java if it is not already in your path.

      I hope this helps, if it doesn't just reply to this thread and I will try to help you some more.


Log in to post a comment.