#21 NMEA Input

closed-fixed
nobody
5
2009-02-17
2009-02-09
ciezar
No

Hello,

I'm testing CapCode, on a windows XP box, using COM2 for NMEA input.
I can not see any info from NMEA.
The com2 dump (using hiperterminal) looks like.
$IIMWV,094.5,R,003.8,N,A*3E
$IIGLL,4122.63,N,00210.94,E,090213,A*3A
$IIVHW,057.0,T,030,M,000.0,N,000.0,K*4A
$IIHDM,030,M*3F
$IIMWV,112,R,004.0,N,A*25
$IIVHW,057.0,T,030,M,000.0,N,000.0,K*4A
$IIMWV,105.5,R,003.8,N,A*37
$IIHDM,029,M*37
$IIGLL,4122.63,N,00210.94,E,090213,A*3A
$IIVHW,013.0,T,029,M,000.0,N,000.0,K*42
$IIMWV,110.5,R,003.7,N,A*3C
$IIHDM,029,M*37
$IIVHW,013.0,T,029,M,000.0,N,000.0,K*42
$IIMWV,066,R,003.5,N,A*25
$IIHDM,028,M*36
$IIGLL,4122.63,N,00210.94,E,090213,A*3A
$IIVHW,043.0,T,028,M,000.0,N,000.0,K*46
$IIMWV,092,R,003.3,N,A*28
$IIHDM,028,M*36
$IIVHW,043.0,T,028,M,000.0,N,000.0,K*46
$IIMWV,099.5,R,003.2,N,A*39
$IIHDM,028,M*36
$IIGLL,4122.63,N,00210.94,E,090213,A*3A
$IIVHW,046.0,T,028,M,000.0,N,000.0,K*43
$IIMWV,091.5,R,003.1,N,A*32
$IIHDM,029,M*37
$IIVHW,046.0,T,029,M,000.0,N,000.0,K*42
$IIMWV,083.5,R,003.3,N,A*33

Any clue?

Thanks a lot
Miguel

Discussion

  • cyrille rosay

    cyrille rosay - 2009-02-14

    hello miguel,
    do you have a message displayed in the console window saying?

    "Stable library

    Native lib version = RXTX-2.1.7
    Java Lib Version = RXTX-2.1.7"

     
  • ciezar

    ciezar - 2009-02-14

    Cyrille,

    Let me send you tomorrow the console feedback. I record some
    good info today, buy I forgot the notebook aboard.
    The main problems seem the capcode have problems to
    understand one NMEA sentence.
    We have a Raymarine ST60, and Seatalk (converted to
    NMEA)send the speed and course in one of the new recommended
    NMEA standars (the console display inform that can not
    understand some sentences). I can not remember well but one
    of this two is not undertood: $IIMWV or $IIVHW
    I'll send you all tomorrow.

    Thanks a lot
    Miguel

     
  • ciezar

    ciezar - 2009-02-16

    Console Output and MWV - Wind Speed and Angle description

     
  • ciezar

    ciezar - 2009-02-16

    File Added: report bug to capcode.txt

     
  • ciezar

    ciezar - 2009-02-16

    Hello,

    Since the MWV NMEA sentence is not known by CapCode, I suposse is a TASK, not a BUG.

     
  • cyrille rosay

    cyrille rosay - 2009-02-16

    this is right Miguel,
    and by the way they is a task allocated to this ( task 2024395)
    but it does not include the MWV message.
    The task has been corrected to integrate this message.
    This will be done in V0.9 (comming very soon)
    thanks for your input.

     
  • cyrille rosay

    cyrille rosay - 2009-02-16
    • status: open --> open-accepted
     
  • cyrille rosay

    cyrille rosay - 2009-02-16

    task 2024395 updated with the MWV message.
    bug pending to closure of this task.

     
  • cyrille rosay

    cyrille rosay - 2009-02-16
    • status: open-accepted --> pending-accepted
     
  • cyrille rosay

    cyrille rosay - 2009-02-16
    • status: pending-accepted --> closed-accepted
     
  • cyrille rosay

    cyrille rosay - 2009-02-16

    correction implemented in beta 0.9

     
  • cyrille rosay

    cyrille rosay - 2009-02-17
    • status: closed-accepted --> closed-fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks