Installing csmash on Madrake 7.1

Help
2000-11-25
2000-12-08
  • Julián Muńoz

    Julián Muńoz - 2000-11-25

    I am a tennis table lover, and Linux also, so I'd like to try csmash !

    If I try to install csmash rpm for Mandrake (found with rpmfind):

    [root@julian src]# rpm -Uvh /home/julian/csmash-0.4.6-2mdk.i586.rpm
    error: failed dependencies:
            rpmlib(PayloadFilesHavePrefix) <= 4.0-1 is needed by csmash-0.4.6-2mdk
            libstdc++-libc6.2-2.so.3 is needed by csmash-0.4.6-2mdk
            rpmlib(CompressedFileNames) <= 3.0.4-1 is needed by csmash-0.4.6-2mdk

    And if I try to compile the rpm:
    rpm -Uvh /home/julian/csmash-0.4.6-2mdk.src.rpm
    only packages with major numbers <= 3 are supported by this version of RPM
    error: /home/julian/csmash-0.4.6-2mdk.src.rpm cannot be installed
    [root@julian src]#

     
    • Kanna Yoshihiro

      Kanna Yoshihiro - 2000-12-01

      The message says that this package depends on rpmlib package, but you haven't installed the package ( or the package you have installed is older than expected).
      Search for the latest version of rpmlib and install it before installing csmash.

       
      • Julián Muńoz

        Julián Muńoz - 2000-12-02

        I have installed previous rpm, for my distrib (Mandrake 7.1), and now it works..... Very slow.
        Should I install Xfree 4 ???

         
        • Kanna Yoshihiro

          Kanna Yoshihiro - 2000-12-04

          No, but you must install OpenGL acceleration driver for your video card.
          And simple mode option (csmash -S) makes this game faster, but more simple.

           
          • Julián Muńoz

            Julián Muńoz - 2000-12-06

            OK !
            I just installed 3dfx "drivers", doing all the steps explained in linux.3dfx.com. The test program works.

            But csmash don't detect nothing, it is still going very very slow. I suppose that it should go to fullscreen mode, overiding all the Xwindow stuff.

            So the mesa library isn't detecting this, or it must be configured ?
            Uhmm, a last try:
            I have uncommented the last lines of
            /usr/X11R6/etc/mesa.conf

            wich are about 3dfx.....

            But that doesn't work!!!!!!!!!!.   ;-((((((((((((((8

             
            • Kanna Yoshihiro

              Kanna Yoshihiro - 2000-12-07

              Hmm, fullscreen mode by '-f' option (like csmash -f) can solve this problem.

               
              • Julián Muńoz

                Julián Muńoz - 2000-12-07

                No, it doesn't work.
                I suppose it has something to do with mesa, which is not recognizing the hardware, or I am doing all the bad way.

                 
              • Julián Muńoz

                Julián Muńoz - 2000-12-07

                Well, I wanted to say: it works, it goes in full screen, but it is still very slow (= not using the 3dfx)

                 
                • Kanna Yoshihiro

                  Kanna Yoshihiro - 2000-12-08

                  Sorry, I have no more good idea...

                  Is any other 3D application works well(runs fast)?
                  If not, how about changing the color mode (8bpp, 15bpp, 16bpp...), or
                  display mode (800x600, 1024x768... ). I heard that some video cards support
                  3D acceleration only on a specific color mode or display mode.

                   

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks