Problem with namespaces

  • Real user 404

    Real user 404 - 2014-06-05


    We happen to have a little issue with the generation of a mind map when namespaces are concerned.

    Let's say wa have a "person" element in a "namespace1" namespace, and a "person" element in a "namespace2" namespace, when I call ref="namespace2:person", in the mindmap it is actually written "namespace1:person", which makes me think maybe CamEditor can sometimes confuse elements with the same name but different namespace.

    Has anybody already reported this problem to you? Do you have any idea why that happened and if there is a way to fix it?

    Thank you in advance!

    PS : I can link you the schemas if needed.

  • drrwebber

    drrwebber - 2014-06-05

    Sounds like a potential bug in the XSLT that generates the mind map.

    If you could send us a link to the schema so I can test it - that would be ideal.

    Once resolved we can provide the patched XSLT for you to run directly.

    Thanks, David

  • Real user 404

    Real user 404 - 2014-06-06

    Thanks a lot.

    Please find attached the schemas (the main one is CDMFR-v1.1.2.xsd).

    Hope you can find what's wrong.

    Thank you in advance!

  • drrwebber

    drrwebber - 2014-06-07

    OK - I've diagnosed this - it is in fact the import from the XSD schema. Turns out its not "wrong" its just different. CAM is trying to minimize use of namespaces and prefixes. So - in your schema XML prolog - instead of using defaultNamespace - you need to explicitly declare the xmlns:cdm directly. And then of course - all ref="name", type="name" etc need to reference ref="cdm:name" and so on.

    I went through and edited all these - and then rebuilt the CAM template. I've attached the results - and the edited schema.

    Also - note - when I imported the XSD - I checked off the "Filter non-UTF8" flag - since you have much French text - and you just want to retain that.

  • Real user 404

    Real user 404 - 2014-06-09

    Thank you for the answer.

    Unfortunately I don't think these changes solved the problem. Indeed, if I check line 347, I can see ref="cdmfr:programDescription" but when I build the CAM model (or look at the one you attached), I still get cdm:programDescription.

    Do you get the same behaviour?

    Thank you in advance!

    Last edit: Real user 404 2014-06-10
  • drrwebber

    drrwebber - 2014-06-11

    OK - I see there is an additional problem. I will have to take a look at the XSLT - see what is tripping up the logic. Thanks for bringing this to our attention. Hopefully it is not a complicated fix... more soon.

  • drrwebber

    drrwebber - 2014-06-23

    Please see attached ZIP of the updated template - I believe I have resolved the schema import issues.

    Let us know. We are working on a new v3.2 release with this patch in it - so once that is out - you will be able to process your schema also.

    Thanks again for reporting this,


  • Real user 404

    Real user 404 - 2014-06-24

    It looks like the namespaces are correct now, but some elements seem to be missing?
    When I look at the mind map, the cdm:program part which had 30 children now only has 8, which is a little bit worrying.

    Thank you in advance.

  • drrwebber

    drrwebber - 2014-06-24

    OK I will take a look at that and see. That is the help I need with verifying the details here. More soon.

    Thanks, David

  • drrwebber

    drrwebber - 2014-06-27

    Appears I was not using the original schema, but one I had doctored to make testing run faster - Ooops!

    Please see attached for updated ZIP.

    Thanks, David

  • Real user 404

    Real user 404 - 2014-06-27

    Wow that is really great.
    I check this afternoon and keep you updated.

    Thanks a lot!

  • Real user 404

    Real user 404 - 2014-06-30


    I have checked the new model, it looks like it is working just fine. Thanks a lot.

    When will the fix be available?

    Thanks again.

  • drrwebber

    drrwebber - 2014-06-30

    New release CAM Editor v3.2 is already available with this fix in - just download and enjoy!

    Thanks again for reporting this and helping us fix it.


  • Real user 404

    Real user 404 - 2014-07-23


    Thank you again for the previous help.

    After some more deep look into the generated model/mind-map, we still believe there are some worrying points :

    1) In the CDMFR-ext schema we define a complexType with <xs:all> (name="prodPeda" line 323), but when I check in the model/mindmap, I cannot find the elements in the "all".

    2) When visualizing the mindmap using Freeplane, I can see some elements are written in blue with a "<" before it. I thought it was a way to represent "choices" elements, but I also found some choices elements just written normally so I could'n really figure out what is the reason for the different style.

    I am looking forward to any lead you could give us on these two issues.

    Thank you in advance!

    PS : I posted in this topic because it is using the same schema already linked in this topic, but I can move it if needed.

    • drrwebber

      drrwebber - 2014-08-04

      Please see attached ZIP.

      Also - can you give me an example of the xsd:choice not being shown in the MindMap with the < blue marking?

      I have looked myself - and so far I only see ones that are now working OK.

      Once you confirm this is now OK - we will do a new CAM v.3.2.1 bug fix release with the new fixes in it.

      Thanks, David

      • Real user 404

        Real user 404 - 2014-08-13

        The new model seems to work now for xs:all elements.

        Concerning an example of xs:choice not shown in blue, element <xs:element name="domainName"> at line 268 of CDM-ext.xsd is a choice but the choices are not displayed in blue in the mind map.

        Thank you in advance

  • drrwebber

    drrwebber - 2014-07-23

    OK - makes sense - let me take a look at what is going on. I know we handle xs:all differently. I saw the blue < choice detail - let me double check to make sure it is matching properly - and if not why.

    Thanks again for inspecting all these details.

  • Real user 404

    Real user 404 - 2014-08-29

    Do you know when version 3.2.1 with the xs:all fix will be released?

    Thank you

  • drrwebber

    drrwebber - 2014-08-29

    Apologies for delay; I'm finishing up the xs:choice bug currently, and then plan is for 3.2.1 release this coming week.

  • Real user 404

    Real user 404 - 2014-09-12

    Did you manage to find why some xs:choice elements are not displayed like the other ones?


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks