On Apr 6, 2005, at 2:48 PM, Shane wrote:

Hi all, I just downloaded 1.0.0-beta1 and (eventually) created a new simple app via the Hello World example.

When I compiled it (zerolink is OFF), tarred it and emailed it to someone, when they run it they get a

2005-04-03 11:53:56 -0400
dyld: /Users/xxx/Desktop/Hello.app/Contents/MacOS/Hello can't open library: CamelBones.framework/CamelBones  (No such file or directory, errno = 2)

Now, when I look in the .app's package contents I see Contents/SharedFrameworks/CamelBones.framework.

I thought that would take care of it, but it didn't.

I went to the xcode-users mailing list archives, and searched there. One person was suggesting (from a prior discussion) a COPY step needs to be created to the build-target. I created this step, and we tried the app on the other non-devel machine, same error.

Any suggestions on the proper way to do this for a camelbones newbie?

First, two notes: For one thing, the beta release of CamelBones won't work on Tiger. And second, it's a beta, so keep that in mind if you "ship" an app that bundles it.

With that in mind, it's actually quite simple. Delete the reference to /Library/Frameworks/CamelBones.framework from your project. Then, add the framework found in /Developer/CamelBones/Frameworks to your project instead. That's the one that's built with the proper linker flags to allow it to be embedded.

Then add a "copy files" build phase to your build target, that copies to the "Frameworks/" directory, and add the CamelBones.framework to it.

The final 1.0 release will probably include project templates that are configured this way by default.

sherm--

Cocoa programming in Perl: http://camelbones.sourceforge.net

Hire me! My resume: http://www.dot-app.org