Buddi: 3.2 Stable Released

Buddi is a simple budgeting program targeted for users with little or no financial background. It allows users to set up accounts and categories, record transactions, check spending habits, etc.

I am happy to announce the first minor stable release on the 3.x branch. This version fixes a few bugs (including a bug when copying your files from OSX 10.4 Tiger to OSX 10.5 Leopard), and resolves a few feature requests. No major changes here, but it is recommended that all users upgrade.

Probably the most notable change to this version is concerning the development and administration. As of version 3.2.0.0, I have merged the Stable and Development branches. This is due to a few reasons:

1) I have no immediate plans for any 'dangerous' changes (i.e., changes which have the potential to corrupt the data model), so there is no need for a dedicated testbed.
2) I can reduce the amount of overhead required to maintain two versions. This will give me more time to attempt to fix reported bugs and address (minor) feature requests.

One thing to note: as promised, the Import Legacy Data Files plugin is no longer built into this version, as it was in the 3.0.0.x branch. If you need to open an old .buddi file (instead of the new default .buddi3), you will have to download the Import Legacy Buddi Data plugin from http://buddi.thecave.homeunix.org/en/download_plugins.php.

Cheers

Posted by Wyatt 2008-05-13

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks