Slow startup

  • elquesogrande

    elquesogrande - 2011-06-02

    After an upgrade to 10.6.7 from 10.5.8, and after applying the Java for Mac OS X 10.6 Update 4, Buddi takes several minutes to launch. The dock icon bounces like normal but then stops. Right clicking on the dock icon shows the app as unresponsive with the option to force quit. However, if I just wait, it eventually launches and works normally.

    I have tried deleting the Buddi app along with the Buddi folder in ~/Library/Application Support/ then restarting and reinstalling Buddi, but the problem remains.

    Any ideas?

  • Wyatt

    Wyatt - 2011-06-02

    That's very odd; I have never seen that before.  Does it happen if you use a different data file?  Is there anything in ~/Library/Logs/Buddi.log?  (You can email me the complete file if you want; my email address is available on the Buddi homepage).

    You can also try a couple other things, depending on your level of familiarity with OSX:

    1) (Easy) Re-downloading the most recent version of Buddi and see if that makes any difference
    2) (Easy - Moderate) Download the .jar version of Buddi, and try double clicking it to run.  It won't have the Buddi icon, but it should start (with a white paper icon).
    3) (Moderate) Try to start the .jar version using the Terminal, to see if there is any messages shown.  Use the command:

    java -jar /path/to/Buddi.jar -log stdout

    where /path/to/Buddi.jar is the path to your downloaded Buddi.jar file, probably ~/Downloads/Buddi.jar

    Let me know if anything helps, hopefully we can figure out what is causing this problem.


  • elquesogrande

    elquesogrande - 2011-06-03

    I tried deleting the Buddi app along with the Buddi folder in ~/Library/Application Support/ then restarting, downloading the installer and reinstalling Buddi. No change. The Buddi Log has references to "Could not load English from /Users/~/Library/Application Support/Buddi/Languages/English.lang:". I looked in that folder and it is empty.

    I also tried to start the .jar version using the Terminal, and the message was essentially the same. Is there supposed to be an English language file in that folder?

    I am emailing you the log file.


  • Wyatt

    Wyatt - 2011-06-03

    Those file not found exceptions are normal; it just means that you have not overridden the default translation.  I'll await your log file and see if that has any additional info…


  • elquesogrande

    elquesogrande - 2011-06-08

    I have Sophos Antivirus installed and that appears to be where the problem is. When I turn off On-Access Scanning in the Sophos Antivirus preferences, Buddi will launch in just a few seconds. I tried a few times with the scanning off and then on, and Buddi launches quickly with it off and slowly when it's on. For now, I'll just turn the scanning off when I need to launch Buddi, and then turn it back on.

  • elquesogrande

    elquesogrande - 2011-06-15

    To further clarify the solution, I checked the support forum at Sophos and found that other people were having the same problem with other Java programs. Putting Buddi or any of its associated files or folders in the "Excluded Items" under "On Access Scanning" in the Sophos preferences does not provide any benefit.

    I found that having "Scan: Inside Archives and Compressed Files" enabled under "On Access Scanning" in the Sophos preferences is where the problem is. Sophos employee Agile states: "Java applications are in effect zip archives with a different extension.  If you disable on-access scanning of archives, this problem should go away for you (as the .jar file doesn't need to be decompressed and each of the hundreds of files inside scanned individually). You don't need to disable on-access scanning."

    I disabled this option and Buddi launches normally without having to turn off On-Access Scanning.


Log in to post a comment.