btqueue on Windows XP SP2

  • SweMart

    SweMart - 2007-04-20


    I've just switched from Solaris to Windows and I'm having problems getting btqueue to start as a service in Windows.

    It just refused and dies with return code 1 according to Windows "services".

    If I start up btqueue manually I see the following:
    C:\Program Files\BTQueue>btqueue.exe scheduler
    >>> FAILURE: Already effectively mapped: BitTorrent TCP external:6881 172.16.17.

    ID Title                Pgr Dn Size ETA Dn/s Up/s Sd Lh State Ratio Activity
    >>> quit
    webservice stopped
    xmlrpc stopped
    queue stopped
    internal queue stopped
    FAILURE: UPnP ERROR: (XP: Port 6881:TCP is bound and is not ours to remove).

    What's the problem? I'm behind a Linksys WRT54GL gateway.

    • Sugree Phatanapherom

      btqueue tried to forward port 6881 automatically via upnp. Anyway, it seems you have already done it manually. You have 2 choices.

      1. turn off upnp in btqueue
      2. disable forwarding port 6881 manually

    • SweMart

      SweMart - 2007-04-21

      I still get the same error message, I edited policy.conf while btqueue wasn't running. btqueue still seem to work but this seems to stop it working as a Windows service. I get return code 1 when trying to start it from Windows services.

      Any tips?

      • Sugree Phatanapherom

        You should try to run btqueue in scheduler module. I'm not sure windows service working properly or not.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks