Akshay Kashyap - 2013-01-14

You'll need XQuartz in addition to the X11 that comes pre-packaged. http://xquartz.macosforge.org/landing/ Just install this and fire up MGED, it ought to run.