Exporting dxf

  • kerry

    kerry - 2011-09-29

    Hello, running BRL CAD on Ubuntu. Trying to export my project as a dxf. I did this:
    g-dxf test.g front_panel.s -o test.dxf
    And it produces some console output but no dxf file. I also get:
    db_lookup(-o) failed: -o does not exist

    The tutorial pdf is ambiguous as to the order of the options. It also is ambiguous as to whether o or -o should be used. Can I just see an example of what to do? Thanks!

    Why isn't dxf an option in the export menu in mged?

    Is it possible to export to 3ds file format?


  • Sean Morrison

    Sean Morrison - 2011-09-29

    Running g-dxf without any arguments provides the following usage:

    Usage: g-dxf    
            brlcad_db.g object(s)

    Order of operations spelled out there indicates the -o option comes before the .g and object names.  Running "g-dxf -o test.dxf test.g front_panel.s" should work in your instance.

    DXF isn't an export menu option in mged simply because nobody has written the code to add them yet.  There is an open to-do item to add them, but all of the devs are fully taxed on other tasks right now.  What you can run within mged is the bot_dump command IFF the object you're trying to export is already a polygonal mesh.  That command has internal support for outputting directly to dxf, stl, and a variety of other formats.  Again, though, the object has to already be a BoT mesh entity (see the 'facetize' mged command or the facetall.sh script in a source distribution).

    BRL-CAD presently does not have a 3ds exporter.


  • kerry

    kerry - 2011-09-30

    Hmm, I thought I had tried that order, but I think the problem was that in the tutorial pdf, on page 37 it says
    "o output.dxf "
    rather than "-o output.dxf" which I should have tried.
    Thank you! I did that, and it produced a dxf file, but I get
    _db_walk_subtree() FAIL on '/front_panel.s'

    What does that mean?

    Looks like I got a lot to learn but BRL-CAD is looking perfect for my needs right now.
    Thanks again!!

  • Sean Morrison

    Sean Morrison - 2011-09-30

    Wow.  You know, that's one of those things that you look at dozens of times over the years and don't see it until someone points it out!  I never noticed that Vol IV doesn't prefix the command options with the requisite dash.  Coincidentally, we're in the process of working on updating those tutorials and other documents too.  I changed the (216) various instances referring to options so they all list the dash now.  Thanks for noticing and pointing it out!.

    Many of the tools, dxf-g included, only recognize solid geometry so they expect  a group or region combination (i.e., an assembly or a part in other terms), not a primitive.  If you add that primitive to a simple group and request that be converted instead of the primitive, it should proceed just fine:

    g mygroup front_panel.s

    Or if you really wanted to structure it properly and mark it as a proper solid region, it'd be something like:

    r myregion.r u front_panel.s
    g mygroup myregion.r

    g-dxf -o file.dxf myfile.g mygroup

    Volumes II and III introduce groups and regions across a series of tutorials and explanations but the MGED Quick Reference summarizes it al in a simple little diagram.



Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks